QNAP NAS package (QPKG) available

Hi, Even I stop develop QPKG for QNAP due to QNAP policy and move to APKG for Asustor … The “original” QPKG (mine) is for all and select the good go exec based on architecture detected. BUT it is not maintains for new QTS version …

As a workaround you can used Entware QPKG this package manager include + 2500 packages including Syncthing. don’t be afraid if version is old … internal update mechanism ask you to upgrade to last version.



Do you have it available for download somewhere? As I said, the link to the QNAP forum is dead unfortunately.

I think it would also work to use my qpkg and just download the syncthing arm executable and overwrite the amd64 one with it after the package was installed. The qpkg is just a wrapper ;-).

I was able to install it via Entware, many thanks!

1 Like

Hi together,

I’ve updated my QPKG build recipe for QTS 5.x and Syncthing v1.18.6 (linux-amd64).

Tested on TVS-EC1080 and TVS-1282.

1 Like

Would it be conceivable that you would use your expertise to continue the now archived Syncthing package for Synology? Unfortunately, I can’t do that, as an ambitious user I have some knowledge, but I just don’t have a background as a programmer.

Sorry, I can’t help here as I don’t own a Synology NAS.

We are running under QNAP’s root account which may be problematic in some future firmware versions, maybe, depending on what strategy QNAP takes.

Same you have now with Synology DSM 7. The package of Safihre from SynoCommunity runs very good in that new environment. The 3rd party installer also can not run longer as root, which was possible up to DSM 6.

Note that Safihre stepped down as maintainer for the SynoCommunity Syncthing SPK package, though he is still around. There are other people (including me) who keep the package alive though, so from my perspective there’s no need to advertise for making a new package for Synology.

1 Like

Thanks @Catfriend1. I was able to download and install that QPKG file on my brand new QNAP TS-1673 NAS (QTS However while it installed, it doesn’t seem to run. Is this version of NAS unsupported, or am I doing something wrong?

Also, I note there is a Syncthing app download available from the QNAP Club website (qnapclub.eu). Is this the same software? There is a list of available versions on the download page (click the download button to drop down the list), but my NAS model is not on the list.

I’ll post a couple of pictures, the first is the icon in the app store, and the second is what I get when I click ‘open’. Clicking ‘open’ again in the dialog window does nothing.


you need to edit /share/CACHEDEVx_DATA/.qpkg/Syncthing/config.xml to activate the Web Gui remote access first and set a port. I didn’t open the web ui to the outside by default as there are still users installing the pkg on their box , wan-exposed, and then complaining the web ui of ST is exposed to everyone outside without a password.

Figured I’d just improve upon this answer regarding support in QNAP devices.

By default, access to the Web GUI is disabled outside of the device itself, so you have to edit the /share/CACHEDEVx_DATA/.qpkg/Syncthing/config.xml file and look for the following:

<gui enabled="true" tls="false" debugging="false">

and ensure that the <address> line is changed from to

Then, if you want to configure the QNAP Admin Page Web GUI to open the application when clicking the open icon for it, you’ll need to edit the /etc/config/qpkg.cfg file and look for the [syncthing] entry in this file (which will be near the end of the file if you just installed the syncthing qpkg package) and add the following to the end of this entry:

WebUI = /
Web_Port = 8384

Ensure you have restarted syncthing via the QNAP Web GUI or via ssh (by running /share/CACHEDEVx_DATA/.qpkg/Syncthing/syncthing.sh restart) and you should now be able to open Synthing via your QNAP IP address or the “open” link in the Web GUI (reload the page after making edits described above).

Note you can also define whatever port number (provided it is available in your QNAP NAS) by replacing 8384 with whatever you prefer in BOTH the config files described above.

Hope this helps.


@ouija Hi,

I’ve changed the QPKG so that the Syncthing Web UI is listening on and can be accessed from the QNAP app center page by clicking on “Open”.

Kind regards, Catfriend1

Link to QPKG download: Release Syncthing QPKG v1.20.4 · Catfriend1/syncthing-msi · GitHub



Link to source which shows how to build the QPKG yourself: syncthing-msi/unrelated_stuff/qpkg at master · Catfriend1/syncthing-msi · GitHub

1 Like

I’ve got a ticket that QNAP Firmware 5.0.1+ doesn’t allow to install/run the package. I’ve fixed that in the recent build of the QPKG.

Link: https://github.com/Catfriend1/syncthing-msi/releases/download/v1.23.0/syncthing_1.23.0_x86_64.qpkg

I forked Catfriend1’s repository and built packages for all archs. I can only test arm_64 on my QNAP TS-233 which works. Any feedback is much appreciated. :slight_smile:


Successfully installed ARMx19 package on very old QNAP TS-219P+ (QTS Syncing some folders worked, CPU and RAM usage is moderate. Thanks!


Thanks for the feedback.

Thank you for this. I’m using x86_64 successfully on my TS-869L.

The web GUI gives me this notice: “Syncthing should not run as a privileged or system user. Please consider using a normal user account.”

Is there a way to run this qpkg as a non-admin user?

Thanks! I’ve tried on my brand new TS-130. I could successfully install the syncthing_1.23.0_arm_64.qpkg package. Unfortunately, I faced the exact same problem as @ben.mcintyre, i.e. clicking ‘open’ on the app does nothing. I can’t make sense of what Catfriend1 and @ouija explained as I can’t find a way to find those directories/files on my QNAP. Looks like a linux path, but I only have Windows installed at home.

Ok, I figure out how to enable Telnet/SSH On QNAP and Windows 10. I had to manualy add the lines in /etc/config/qpkg.conf as explained by @ouija. This then solves the issue and I could successfully open the Syncthing WEB UI. Thank you guys for the tricks !

1 Like