QNAP NAS package (QPKG) available


(father_mande) #1

Hi,

F.Y.I. … a QPKG … Qnap PacKaGe (community) is now available for ALL QNAP models … based on binary 0.9.9 supply here (without modification)

QPKG exist for x86, x86_64, Armv5 … and is also under test for new series …

QPKG manage : GUI integration in QTS desktop … change parameters to match with QNAP constraint … start / stop / autorun mechanism … Upnp IGD integration

next QPKG (attach or not to new version) will provide … extend parameters (not in GUI) … access to GUI through Apache Proxy … start under user vs. admin today …

I will inform you about return from first users … for now it work on my own …

Thanks for all your work … best regards. Philippe.


(Nick Pyz) #2

Good news, Philippe! When you are finished testing, you might want to post a public download link to the QNAP package in the Syncthing Community wiki here:

https://forum.syncthing.net/t/community-contributions/611?source_topic_id=793

(father_mande) #3

Hi,

No problem … I will add the link … when I will be sure that all run fine (fine = corresponding to the normal usage of Synncthing for the version, and without problem added by QNAP firmware)

For QNAP’s users the Beta link is :

need a (free) registration to QNAP official forum

Please QNAP’s users … if problem seems to be in the QPKG … put your message in QNAP forum … don’t pollute this forum with QNAP integration …

Philippe. Sorry if my English is not “clear” … I am French … nobody is perfect …


(father_mande) #4

Hi, For Your Information : New QPKG (Qnap Package) version is available for QNAP users … seem to be the RC one … integrate 0.9.10 … to have syncthing up to date also

ADD using the daemon manager in Qnap ADD integration to use QNAP / signed certificate to access GUI using HTTPS (so no twice cert. no specific port to open … ) ADD rotate log to follow usage and error (can be set or unset by command) Solve some integration problem specific to armv5 plate-form (QNAP side) validate internal-update and provide tools to update the corresponding version in QPKG (Qnap visibility) suppress any ref. to root (admin)

RC is available through the same link … as before …

Wait return from users … then validate it as “stable” … then add some others things to manage easily (xml edition) the config.xml parameters

Philippe.


(father_mande) #5

Hi, … updated to 0.9.13 Seems all is now stable … including internal update

I will change from Beta to R.C.

Previous link to QNAP is always available (file version is managed at qnapclub.fr site … ) same link but actual and previous versions are available … (in case of)

I will update Wiki soon …

Philippe.


(Jochen) #6

Thank you @Philippe for this package. Just installed on my qnap (HS-210) successfully. Seems to work well. Getting same error as shown here: I think this calls for a celebration :) Found ‘cert.pem’ in config directory of your package. Guess it need to get moved? Of course, care must be taken not to override existing certs. Also, https access would be nice. If it exists already I cannot work out easily. Last but not least: Understand it is quite difficult to keep your package in sync with syncthing frequent release cycle. Is it save to update via syncthing or better to wait for your package update? Keep up your efforts!


(father_mande) #7

Hi schijo,

Https access is a little difficult by adding new certificate … so I have managed to use the SSL proxy provide by QNAP … so no need to add new certificate and you can share a “purchased” certificate if you have one for the QNAP …

For the error, please can you explain exactly what you do ?

It is safe to use the internal update mechanism … after a successful update … use the command line to reflect the new version in App. Center … to don’t be confuse … I will do it automatically in next release …

The new version is for people wanting to update using QNAP mechanism OR for new to start immediately with the last version …

Philippe.


(Jochen) #8

As for the error: Not doing much. It’s the automated statistics process running in background. It attempts to send my stats to syncthing but that’s not working due to broken (i.e. not found) certificate required to connect to their Website. See previous link in my previous post for details.


(father_mande) #9

Hi,

Don’t have lot of time to search this week (next is better) If the problem is that Syncthing site use a signed SSL certificate … perhaps it’s due to CA-Certificates that are NOT provide in QNAP To solve this (or test) … you can use another of my QPKG named ca_mega_dropbox … this QPKG add command line interface for Dropbox and Mega … but it’s only two scripts so … no spaces really used .To WORK mega and dropbox need that script will be able to manage certificates … so the ca (CA) of the name is for CA-Certificate that are added to QNAP …

Try to install the QPKG … then ignore command line … then test … if it’s a server certificate … it can run … QPKG : http://forum.qnap.com/viewtopic.php?f=320&t=90770&start=15#p400454 If this work I will integrate ca-certificates inside the Syncthing QPKG

If I not I will search …

Philippe.


(father_mande) #10

Hi,

Just for your information :smile:

V 0.10.0 is now on line as a QNAP QPKG (for update or new fresh install) (we have for now … more than 100 download … so perhaps QNAP users seems to be interested by this :smile: … )

This version add the support for new series TS-x31 based on freescale S.O.C.

The problem linked to ca-certificates … will be solved (integrated in the QPKG) with the next release (QPKG) , even without Synthing version change … just wait … I am busy next week but manage to add it after.

Philippe.


#12

Hey will your package once be capable of run syncthing in different instances? So that there would be one for User1 and an other for User2. Because at the moment it runs syncthing as admin and when it syncs files, created on an remote computer, the files are not accessible from the owner on the Qnap, only from admin. It would be nice to have something like a multi-user-functionality :wink:


(father_mande) #14

Hi,

Basically running Syncthing under another user is not at all a big problem, I can add this BUT running multiple instance for multiple user ??? Even if possible power need must be bigger than NAS possibility … and I don’t know if linking a user to a share is in the product ??? because in each operating system, the method is different and UID are multiple even for different name … So first possibility : run syncthing under user account … is easy (I can integrate it in a next release)

Another solution … is to dedicate folder to user and use in parallel inotify to change the owner when a file is write (on Linux like QNAP box) … but it’s to build as specific to any kind of system … so not with the product …

Philippe.


#15

Hm, yes the power of the NAS is indeed a problem :stuck_out_tongue: So actually I need only the possibility to run syncthing under an other user than “admin” because of the problems withe the ownerrights. Maybe a real multiuserfunctionality should be implemented directly in syncthing.

Thanks for your work so far!


(Mapleshadow) #16

非常感谢!!!希望能尽快支持! Thanks a million. Would you please support!


#17

Is there an update for syncthing 0.11?


(father_mande) #18

Hi,

An update will be available in short time … I will made some tests before providing it and add possible parameters for small Arm model with limited memory … Please wait.

BUT as usual if it’s urgent, you can manually upgrade as any default delivery …

Philippe. NB the release is one day ago … so please … I am a qnap user, not a all time developer / integrator on it and not from QNAP’s group …


#19

No problem :smile: Thank you very much for youor work!!


(father_mande) #20

Hi,

Version 0.11.0 is now available in QNAP forum as usual …

Added syncthing-cli (arm,x86) for command line access Added syncthing-inotify (arm,x86) for using inotify in place of time rescan …

Philippe.


#21

Hi,

First of all thank you to Philippe for his work on this.

Forgive my almost complete ignorance, but are we supposed to install this on top of the previous one, or do we have to uninstall? And for uninstalling is it enough to right-clic-“remove” on the start screen or is there something else? Do I have to take note of the paths etc. or will it all be kept during the update process? Thanks!


(father_mande) #22

Hi,

It’s an update … and the update mechanism (like explain here (re-index, save old for 2 weeks, etc.)) is the same … so you can install this under your .10 version BUT as it is said … update all at the same time …

Philippe.