How to install Syncthing (arm release) on Synology?


Could someone please point me to a proper and concise guide to install and further auto-update the official Syncthing release on my Synology DS213j ? The tar.gz package for arm devices, not the .spk from Cytek. I’ve been looking for a tuto here and there for a few days, no success so far.

I’m not a very Linux-guy but, in desperation, I could try to adapt this Raspberry Pi tuto accordingly, with the hope not to mess system files.

Thanks in advance.

I don’t know any tutorial but I did install syncthing on a DS214 like this:

  1. create user st and add to admin group to get access to all files and folders
  2. login to ssh as root
  3. switch to user st with su -s /bin/ash st
  4. go to home dir with cd (which should bring you to /volume1/homes/st/
  5. download and extract syncthing arm version; and move syncthing binary from sub folder to home folder
  6. start syncthing, let it create certs and config, then kill it
  7. edit config to change web ui from to

To start syncthing on boot, you can add su -s /bin/ash -c /volume1/homes/st/syncthing st to rc.local or you can create a task in synogolgy ui which executes ash su -s /bin/ash -c /volume1/homes/st/syncthing st to run it manually (disable schedule) (thats what I did)

volume1/can be different on your NAS, depending on where the user home dirs are located.


Wow… first of all, many thanks, I’ll try right now. Installing ipkg for the time being…

I’m the sole user of my Syno and my user account belongs to admin group. Can I use my account to proceed ?

I managed to install it. Be blessed, man !

Now the service stops whenever I close the SSH (Putty) Windows. how can I keep the service running ?

And also, will it survive to a DSM update ?

That’s what the text below the list was for :slight_smile: You can add it to /etc/rc.local (create if it doesn’t exist yet) or create a scheduled task in DSM settings and disable it to start it manually when needed (that’s what I did) The command for the scheduled task is ash su -s /bin/ash -c /volume1/homes/st/syncthing (where st is to be replaced with the username you used) I did not test the rc.local approach and on my NAS the file does not exist.

It should survive DSM update, as it is completely in home dir. I don’t know if it did setup syncthing before or after the last auto DSM update, so I can’t attest to that.

By the way, ipkg is not necessary. I don’t have it installed.

Install the Cytek version and follow the tutorial on some modifications to the start-stop-status script. Then replace /usr/local/syncthing/bin/syncthing with the latest ARM release and you should be good to go. Benefits of this method: the ability to start and stop via DSM web interface, and automatic start via DSM.

Apparently, the cytec repository discontinued Syncthing downloads on 03/25/2015. It seems that SynoCommunity is the new source for Syncthing on Synology.

I am waiting for some confirmation from the 2 repositories, and then I will update the ST Community-Contributions wiki.

Hello all, sorry to have been away for so long (IRL stuff…).

I’ve finally dropped the version installed via the tuto mentioned above and picked the Synocommunity version. Seems to be running +/- smoothly as the previous one, with the same quirks though (Folder not making progress, etc.)

Thank you for your information! I’ve installed Syncthing on my NAS but the services stops when I close my SSH session (same as at princejosuah). I tried to use your scheduled task command but unfortunately it doesn’t work. I can start Syncthing from a SSH terminal and use su -s /bin/ash st as you said. Syncthing will run as the st user so I don’t think it’s a permission problem. What else can I try?

did you put the ash at the beginning of the command for the scheduled task? This was not a typo or anything. ash is the shell on the NAS (at least on my 214). Without that, the task does not work.

Hello @barido

If you install the package from Synocommunity as I described above, it’s pretty straight forward and you’ll certainly avoid so much hassle. Plus you’ll be able to launch it as any other Synology package from the menu.

Please let us know how it turns.

1 Like

If you, after installing the package, replace the main executable with one from github, you also get automatic updates. :smile:

Thanks for your reply. I did put ash at the beginning of the command. I also tried to run is as a different user. I tried “root” and “st”.

I’ve installed the package from Synocommunity but it won’t start. I set it to “execute” in the package manager but nothing happens. The github version runs fine without lots of CPU load or RAM usage.

How is this done? I have putty and have logged in via SSH but cant see where the executable is located

I think the executable should be there:

Yes I see the file ‘syncthing’ which file should I download and how to replace it on the NAS?

I’ve stopped syncthing and tried to delete with rm syncthing but got permission denied

I installed the Synocommunity version replaced the “syncthing”, but the webgui gives an error…

You have to download the “arm” build i guess. Which CPU is in your Synology?

Maybe it was installed under a different user. You can try to replace it with root rights. (Be sure to chomd and chown correctly afterwards)

Which Error do you get? Can you paste some Screenshot or something?