Unable to sync documents or files ending with period(.) symbol

Unable to sync documents or files ending with period(.) symbol.

From Android to Windows.

Is there a possible solution to this issue on Windows.

1 Like

Windows does not permit files ending with a dot, so the only solution is to rename the files.

2 Likes

Thanks again!!!

A suggestion though, there should be an feature for ignoring file systems and copy anyways, as it is possible directly from Android to Windows USB condition.

Usb’s are never formatted using NTFS, and OS drives are usually NTFS, which is where this limitation comes from, so you can’t just “ignore” stuff.

Thank you for the response. I mean when the same Android phone is connected via USB, the copying works properly. No errors whatsoever.

Do the files actually still have their final period once copied that way? Normally, both CMD and Explorer will strip the final dot if you try to force them to create a file or folder named like that.

Yes.Tried and tested just now again with Windows 10(20H2). Previously, I used to connect my Android phone to Windows PC via USB and copy all my phone contents and then reset it.

P.S: The documents or files I’m trying to auto-sync is actually pdf file in WhatsApp from WhatsApp Documents===>Sent Folder. They are stored ending with period(.) format by WhatsApp(for security I think) .

Interesting. There are ways to force the creation of some of the “illegal” filenames in Windows, but it has a very big disadvantage of not being able to use standard tools to deal with them later. This means that a non-technical user will end up with files that they cannot rename or delete. Thus, Syncthing has chosen an approach to block the creation of such files from the get-go.

To sum up, there is no way to sync those files currently, unless you modify the code removing the restrictions, and then compile your own custom build.

I am not sure if something wrong is being talked about here. It is correct, in Windows there are no files with xyz. but only xyz or xyz.txt or like that. And such files are also synchronized.

However, in your example with WhatsApp on my Android smartphone there are no folders or files with xyz. in the entire folder structure but at most .xyz and these are all synchronized via Syncthing. In addition, all attachments are stored in the SENT with their full names, e.g. xyz.PDF or xyz.DOC which are also synced.

What kind of smartphone do you have with which OS? Have these things always been like that?

FYI, Android 11.Samsung S10. I’m able to open the files in Windows (any pdf reader), it works fine. Only the file names are same with period(.) at the end. These files are mainly pdf files or images sometimes.

P.S: It is with Android to Windows via USB and not with Syncthing.

I’m able to open the files in Windows (any pdf reader), it works fine.

These files are sent as documents in WhatsApp to other users.

It is strange. I only sync via WLAN and the files are transferred perfectly. I have Samsung Note 8 with Android 9. Maybe it’s related to the Android version?

However, for that syncs I use the Syncthing-Fork version and for internal syncs the official Syncthing version as second instance, but finally it makes no difference.

The NTFS, exFAT, FAT32, and reFS filesystems allow you to create a filename ending with a period or a space. To check that’s true, just type in CMD:

echo >"\\?\%TEMP%\dot."

or

echo >"\\?\%TEMP%\space "

Many programs, such as File Explorer or CMD, will not open “%TEMP%\dot.” but will happily open “\\?\%TEMP%\dot.”

While Syncthing can create these files, as it prepends “\\?\” on all filenames, it has code that checks if the filename ends in a period or space, and if it does, it fails with an error message.

This check could be removed. If it was, then Windows programs would have trouble opening these files, unless you prepend the filename with \\?\.

For more information, see https://ss64.com/nt/syntax-filenames.html and a potential fix at

How can i ignore these files? I’ve tried /WhatsApp/**/*. // files ending with period!, but SyncThing still shows them as Out of Sync.

Syncthing doesn’t do slash-slash comments in the middle of ignore patterns. Try:

/WhatsApp/**/*.

that didn’t work unfortunately. i made sure to Rescan All, but they still show up as Out of Sync :frowning:

How about just *.? Does it also not work?

Also doesn’t work. It still says that 9 files are Out of Sync, but when i click the link to view the list, the list is empty. Already restartet SyncThing :confused:

For ignoring these files, add *. in ignore patterns by editing the folder configurations.

I tried it right now and previuosly, it definitely works. But I don’t want these files to be ignored, so removed the tags from ignore patterns. Eagerly, waiting for an update to SyncTrazor, where it copies, irrespective of underlying file system.

Hope this helps you.

Without ignore patterns

With ignore patterns

1 Like