Blocked IP addresses in Russia

(Sergey) #1

In the fight to ban the messenger Telegram, the Russian government blocked a large number of IP addresses. In this lock were the domain names Is there a way to make the program workable in this situation?

Comp stopped syncing how detect where is a problem ?
Comp stopped syncing how detect where is a problem ?
(Audrius Butkevicius) #2

It feels like you have syncthing misconfigured, as I think those discovery servers have been deprecated.

(Audrius Butkevicius) #3

Just remove the custom discovery addresses and set the field value to “default”.

(Sergey) #4
  1. Until April 16, 2018, the synchronization worked. On the site, about blocking ip addresses, the information coincides that these addresses were blocked on April 16.
  2. In the program, I did not make any adjustments, these addresses are set by default. I would be happy if you tell me where and to what addresses I can replace?

(Simon) #5

I think new urls have recently been introduced, but the old ones purposely still work to keep it working for the pretty significant userbase on old versions.

(Jakob Borg) #6

I guess someone can set up discovery servers in Russia for russian users, or you can wait for the hysteria to pass and the blocking to be released maybe.

(From the no-such-host reply I’m guessing it’s maybe cloudflare’s dns that’s blocked?)

(Sergey) #7

I have 2 hardware devices:

  1. QNAP NAS, the installed version of v0.14.46, Linux (ARM) (This is the latest version.)
  2. free4nas v0.14.30, FreeBSD (32 bit).

QNAP also has error messages:

Sorry that inserted a screenshot, not text, since the new user can not publish more than 1 link.

(Sergey) #8

It is also unclear why the status of “Discovery” is 2/5. If there is no connection, then should be 0/5?


(Audrius Butkevicius) #9

Local discovery over ipv6 and 4 counts as one each

(Ildar Yusupov) #10

Excuse me, I have connectivity problem too (Russia): One device (win pc) cannot see another devices (also win pc, another network). Everyithing was working yesterday, no changes was made.

How can I find a reason of this problem?

(Ivan Ponomarev) #11

Good day, why the device has ceased to see each other (Russia), problems arise with the update, the server forcibly close the connection. What’s the matter? Who is aware of?

(Ildar Yusupov) #12

Connectivity is restored, thank you, friends!!!

(Pavel) #13

I can’t confirm. Last time I saw my three devices working was 24/4. Luckily 2 of them have static IPs so I set direct address in settings to make them see each other again. Here are the discovery errors.

device #1:

global@ Post dial tcp connectex: No connection could be made because the target machine actively refused it.

global@ Post dial tcp: lookup no such host

device #2:

global@ Post read tcp XX.XX.XX.XX:XXXXX-> read: connection reset by peer

global@ Post dial tcp [2001:bc8:4700:2000::515]:443: connect: network is unreachable

device #3 (without static IP):

global@ Post read tcp> wsarecv: An existing connection was forcibly closed by the remote host.

global@ Post dial tcp: lookup no such host

(Jakob Borg) #14

Just so that everyone’s on the same page - the discovery connectivity or lack thereof in Russia is unfortunately completely outside of our control.

You’re all welcome to discuss & report of course, just be aware that any changes you see - positive or negative - are not due to actions by the Syncthing team.

(Vacore) #15

I’m from Russia too, and I’ve encountered the problem described in May be these are related?


Have own discovery server (not located in Russia). Would the Russian’s in this thread like to try to use it?

(Pavel) #17

Sure! :slight_smile:

(Ildar Yusupov) #18

My 2 cents: discovery problems are not persistent - sometimes nodes see each other, but not too long.

p.s. I like to try another discovery server. How can we do this?


Let know how it works for you. If many find useful will run as proper community contribution by moving to dot com with SSL certificate (making device ID not necessary) on port 443. Currently runs on port 8443 so will not work when only port 80 and 443 outgoing allowed.

(Pavel) #20

Works perfectly, thank you!:+1: