Device connection problem

I’m sorry. I have a problem. Lost connection between many devices. It worked without problems for a long time.

I can’t post the log in this thread, it’s available via the link.

log.txt (3.5 KB)

The log doesn’t really say much, except for the fact that Syncthing was unable to connect in order obtain information about the current version and possibly perform an auto-upgrade.

Please provide more details about how you’ve been using Syncthing so far, what kind of devices you’ve got, the operating systems, the type of networking, etc. Do you use default settings, or have you fiddled around with some of them (e.g. discovery or relaying)? Please also check your firewalls whether they’re not blocking anything related to Syncthing.

Lastly, it’s always good to upload screenshots showing the Syncthing Web GUI on all affected devices to provide some visual clues that otherwise could easily be missed.

I am using the default settings. I share from a server running with Mac OS for 80 devices with Windows. All devices use NAT. In the pictures, the maсos from which files are distributed and one of the non-connectable devices

The screenshots show Syncthing v1.13.1. Is there any reason for sticking to the old version? There’s also a discrepancy between this information and the log, which shows Syncthing v1.20.1 (but the folder name says v1.13.1).

Are you sure there’re no problems regarding Internet connectivity in general? The clue here is Syncthing being unable to connect to its upgrade-related address, yet it still connects to relays and such, which would indicate that the Internet isn’t completely blocked on the device either.

The devices connected after being idle for a day. It is not clear what it was. The Internet has always been on all devices. The provider did not block connections on ports. Didn’t have time to analyze. Thanks for your help.

However, the devices stopped connecting again. I can’t find the reason. I solved the connection problem with by running the program as administrator and updated to the latest version. Can you help please?

Can’t really help much more, but it does look some kind of a firewall/network-related issue, especially if you can connect to the address using the Administrator account, but you cannot do the same with the user account. You may want to experiment with creating a completely new user account and checking whether the connection works there or not. You may also try disabling Windows Firewall completely and see what happens then.

1 Like

No address is discovered for the remote and discovery shows 3/5 - click on that to see which discovery methods are not working. I’d check discovery on both involved devices (post screenshots). As tomasz wrote, likely that some firewall gets in the way.

1 Like

I get this answer. Attached a screenshot. At the same time, I can resolve the address The firewall on the device is disabled.

May be unrelated, but the situation here looks very similar (or exactly the same if you look at the screenshots) to what was reported yesterday in


Indeed. It’s not on our side though; I suspect network issues, intentional or otherwise. Our hosting has historically been blocked, from some parts of the world. The other dude looks Russian, and your terminal speaks Russian, so I’m getting a feeling there’s a common factor.


Yes, it is very similar to blocking at the state level. Trying to figure it out

For the record: some of the big ISPs in Russia (not all) have recently started dropping packets going to port 443 on some of the servers (again, not all) hosted by Digital Ocean. Could be the explanation here.


It stopped working for me too. I’m in Russia

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.