If you’re using a release prior to 0.14.46 (released April 4, 2018) you need to upgrade. Especially if you are here to let us know that it crashes.
Specifically, those old versions have problems with large / variable blocks which are default in 1.1.0+ and mandatory in 1.2.0+ (coming soon).
You cannot have a cluster with some devices at 1.2.0 and newer and some other devices on 0.14.45 or older. You need to either get with the newer program, or remain on the older.
For most users this isn’t a problem - they will be on something new already. Notable exceptions are Debian which ship quite an old version. That’s fine if all you run is Debian. If you want to combine Debian with something more modern, consider using our APT repository at https://apt.syncthing.net/ directly.
Thank you for your attention.