Folders are "up to date" but devices show "syncing" with no change


I have two devices (Windows & Linux machine) syncing three folders via SyncThing. All foders are shown as “Up to date” with no out-of-sync items.

However, in the “remote device” section, both devices show “syncing”, but have zero progress on that - also, no data is exchanged between the two devices as per the bitrate that is used.

Syncing new changes in the folders works flawlessly.

What is causing this problem?

Here is also a screenshot that shows more detailed states:

In a recent similar report the reason was database corruption due to crashes in the past. Can you check logs for occurrence of “panic”.

@AudriusButkevicius @calmh Might it make sense to ship cmd/stindex in release or integrate it in Syncthing. At first to check db consistency, but for some errors to repair them too (like the recent one were entries were missing only in the sequence bucket). Repairing is far faster than dropping and rebuilding the index. Of course we should just fix the underlying problem, but if it’s really because of crashes, that will hardly ever be possible 100%.

I have run in the same situation with the panic logs on the host “S3”. And that’s the only remote host being shown on other hosts “syncing”. On host “S3” I had a lot of panic logs. I have deleted database on host S3 and other 2 PC’s (haven’t done it on 3 other PC’s) as they are located far away, but after syncing all stuff I get panic logs and still no complete syncing happens…

I still see the panic logs with “out of memory”. All boxes are Win10, except S3 with OpenBSD. All the latest v1.3.3.

So I should probably resolve this issue with resolving “out of memory” error? Although I previously had an old OpenBSD 5.x something, everything worked fine. I reinstalled it now to latest 6.6. It’s a VM on VMWare. Previously it had 4GB RAM and it was enough. Now I have raised it to 40GB, still hanging up with out of memory error…


in my syncthing logs, I did not find any mentioning of “panic”. Unfortunately, only one device has logfiles - the other doesn’t have one (synology NAS server with syncthing package)

How can I repair the database? Or should I go ahead and force a rescan by deleting the database files?

Thank you very much in advance!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.