Write access to binary for Syncthing GTK

I have Syncthing GTK installed on Ubuntu under the KDE desktop. When I clicked the “Keep Syncthing binary up-to-date” checkbox, I got the output “No access to daemon binary. Skipping update check”

Can anyone help so that Syncthing GTK can get access to the binary?

Ping @kozec

Aaahem, sorry for late response, I still didn’t find where exactly are all notification mails disappearing.

“No access to daemon binary” message is shown if user has no write access either to syncthing binary or to parent directory. If you have syncthing in /usr/bin, that’s exactly that type of location.

@kozec how can i change that?

Did you placed it there manually? If not, it may be probably best to left updating to package manager.

Or you can remove binary and start ST-GTK without it. It should display “Cannot invoke daemon” message. Check, if path displayed there points somewhere in your home folder, click on Download button and enable autoupdating after restart.

1 Like

Yes i did remove the binarys in the home folder and pointed ST-GTK to this folder in the setting. Now it seams to work.