"no write access to daemon binary"

Hi, I have tried deleting usr/bin/syncthing as mentioned in this post (Write access to binary for Syncthing GTK) but still have the error message.

The daemon advanced section shows the bin location to be /app/bin/syncthing but this doesn’t exist.

Rgds, Tony Daemon v1.1.3 Desktop: MATE 1.20.1 Distro: Linux Mint 19.1 Tessa

You should start by explaining what you are trying to do and what you’ve done so far.

Hi,

please see an expanded explanation

I am trying to ensure I am using teh latest Daemon. In UI settings _ Daemon, I ticked “Keep SyncThing Binary up to date”

I then received the error message “no-write-access-to-daemon-binary”

I found a previous post “https://forum.syncthing.net/t/write-access-to-binary-for-syncthing-gtk/5342/2” referencing this issue… which recommended deleting /usr/bin/syncthing.

When I deleted this, I still have the same error message.

I then checked UI settings – Advanced, which tells me that the Binary should be in /app/bin/syncthing… but it isn’t.

My question is…

how do I avoid the “no-write-access-to-daemon-binary” error so that I can keep the daemon up to date?

Best regards, Tony

How did you install Syncthing?

Hi, this was installed via Mint Software Manager and used Syncthing’s default settings.

Please see terminal info:-

tony@tony-Latitude-E6430:~$ apt policy syncthing

syncthing:

Installed: 0.14.43+ds1-6

Candidate: 0.14.43+ds1-6

Version table:

*** 0.14.43+ds1-6 500

    500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
    100 /var/lib/dpkg/status

Best regards, Tony

`

If you want to use apt and have the newest Syncthing version, use https://apt.syncthing.net/ (system wide installation). If you want syncthing to handle update by itself, download the binary from github (https://github.com/syncthing/syncthing/releases/latest) and place it e.g. in ~/.local/bin or wherever you want and have write access and point syncthing-gtk at that location. In that case do not manually delete /usr/bin/syncthing, use apt remove syncthing (that’s always true, not specific to this case).

Thanks Simon