Windows: Syncthing is not detecting changes in folder even after manual rescan

I’m trying to sync a folder on a Windows 10 machine with a folder on a Raspberry Pi. Both are running Syncthing version 1.27.7. The folder currently contains 8 PDF files with a total size of 9MB. The Raspi is set to “receive only”.

When I change the files on the Raspi, it is reflected in the “local state” but, as the folder is “receive only”, it doesn’t send the changes to the Windows machine so the global and the local state differ.

However, if I change the files on the Windows machine, its local state doesn’t change (and then, of course, the changes are not sent to the Raspi). The local state doesn’t change even if I make a manual rescan.

I read that this might be related to the installation method on the Windows machine. I specifically chose to install for the local user only, because installing globally for all users might lead to problems as in windows not uploading data However, I need to note, that the user in question has administrative privileges, if this matters.

I tried to add “SyncthingServiceAcct” to the folder’s properties, as described in the thread I linked above, but such a keyword isn’t being found and I’m not sure how to proceed.

Hints on how to solve this issue are appreciated!

Best, Photon89

the “SyncthingServiceAcct” is only created when syncthing is installed for all users (administrative installation), and that did fix original problem that windows didnt upload data.

I see, thanks for the explanation! So, looks like the issue is somewhere else!

Can I provide any further information to help diagnose this issue?

Screenshots, logs after having run a manual scan.

Will do, probably tomorrow, thanks!

Here are some screenshots:

As you can see, in the beginning there are 8 PDF files and this is reflected by Syncthing (screenshot 1). I tried adding the file test.txt to the 8 PDF files which are already present. However, the newly added file isn’t picked up (screenshot 2). In the logs, all other files are there but not the test.txt file… (screenshot 3)

Please let me know, if you need something else! I also added which debug options I selected (screenshot 4). Thanks!

You have C:\Users\ABITS\Dokumente vs C:\Users\ABITS\Documents. It’s not clear those refer to the same folder. Sometimes the GUI presents localised versions, but generally that’s not the path Syncthing will see, and apparently you see Documents and not Dokumente in the Explorer, so I’d sort out that discrepancy first.

1 Like

That’s a good catch, thanks for the hint! I’ll try it as soon as I have access to the machine again!

I’m not very optimistic that this is the culprit though, as Syncthing can successfully find the eight files that were present initially, according to the logs. I will try to eliminate this possibility though and report back as soon as I could test it!

My suspicion is that Syncthing created Dokumente and synced the files there from some other host, but you’re editing in Documents which is a different place…

1 Like

I might have the same kind of issue (Win 10, Syncthing 1.27.7, wrapped by SyncTrayzor 1.1.29). I basically have at least one folder for which Syncthing seems like it doesn’t want to sync anymore.

Here are some screenshot to illustrate, I do have logs but I can’t find anything relevant there. Manual rescan just “rescan” but still tells me nothing changed, and I tried restarting syncthing, restarting Synctrayzor, even restarted the whole PC.

(last scan is obscured but it was from 2 minutes prior to the screenshot and not another day)

Subfolder that have “updates” as seen in the “date modified” column (some files are new, main “comptes.gnucash” file was modified) :slight_smile: image

EDIT for some logs: I tried activating the walkfs & watchaggregator debug logs and created a random excel file, they do seem to detect it, but no idea as to why it doesn’t get updated into the folder monitoring itself, which debug option can I add in order to see where it goes wrong?

I tested it today and you were completely right, the different naming was the issue. I deleted the shared folder in Syncthing, readded it, this time with “Documents” instead of “Dokumente” in the folder’s path and it works like a charm now!

3 Likes