windows not uploading data

today i installed syncthing on my truenas scale nas using jailmaker and dockage. its working great as expected but my windows desktop is not uploading data, i isolated the issue to windows by successfully syncing data from my phone. the windows node can receive data as i used it to sync to for the last couple of months.

Have you configured the permissions for the service user under security settings? image

1 Like

how do i do this?

Right-click on the folder → Properties → Security → Edit → Click “Add” and type “SyncthingServiceAcct” → Click “OK” → Check the box for “Modify” → Apply and then try the sync again.

1 Like

thank you that worked great. but now im starting to get permission errors for files on my server, im not sure why i have set the syncthing user to have full control and recursive permissions but still. but its not a problem with syncthing so ill go ask on truenas help forum.

update: this permission is only when i upload from Windows for some unknown reason as when i upload the data from Windows to my phone everything works great

If you installed Syncthing using Syncthing Windows Setup and you installed for all users (administrator/service), you must manually grant file permissions to the service account.

If you uninstall for all users and reinstall for your current user only (non admin), manual permission changes should not be necessary if you sync folders that exist in your user profile. This is because, in this case, Syncthing is running as the current user (and the current user already has permissions to files and folders in their own profile).

This is all spelled out in the documentation; see the section Administrative vs. Non Administrative Installation Mode.

i reinstalled syncthing for all users and granted permission to the folder i want to sync and it worked when i tried to sync this data to my phone but when i try to upload it to my nas i get permission errors on my nas side which shouldn’t happen, as the syncthing user is the owner of the directories im syncing to and has more permission then it needs. and on top of that i can sync data from my phone to the nas without any problems.