Watch for changes error while traversing share subfolder

I got the problem reported in this topic:

https://forum.syncthing.net/t/watch-for-changes-error-while-traversing-share-subfolder-permission-denied/

SyncThing 1.4.0 on a Synology NAS.

Even moving the subfolder on another folder I got the same result. The owner properties are the same as other subfolders working OK.

I also run 3 Synology with Syncthing and I have had this problem with 2 of 3 servers for a long time. I have also worked and experimented with the permissions and ACLs, but no change. The messages look like this to me:

However, I can say so much that these messages have no effect on the quality of the processes. These are flawless.

Furthermore, there seems to be a connection with the number of peers that are connected. 2 of the 3 servers have around 50 peers, most of which are connected between these two servers via the Internet, that is 37 peers. When establishing the connections to the peers, it started somewhere in the middle, approx.> 20 peers, that these messages came and have been present since then.

With the third Synology, on which Syncthing only managed 7 peers, I never had these messages.

Or shorter: the only solution i have ever seen that works is butchering synology (manually removing ACLs). synology will probably fight back though at some point. the only definite solution is to get a sane system (1. requirement: not Synology).

sorry for the rant, it felt good though :smiley:

1 Like

Is tested, no influence.

Understood … :wink: … you are not the big friend of Synology. However, NAS are very popular, especially Synology, I think your pious wish will remain. You also have more, some of which are also very common: QNAP, Western Digital, Drobo, Asus, Seagate, Netgear etc. … :innocent:

And, I repeat that if you follow a few rules, Syncthing will do very well on Synologys. I am not deterred by such messages and it seems, is also the same for others.

Nonetheless, Synology seems rather over represented when it comes to mysterious sync failures, permission problems, and database corruption.

Historically, NAS hardware (all brands) have been cheaper and lower end than what you’ll find in “normal computers”. That plus oddball implementations of users, filesystems, RAID, permissions, etc seem to result in higher than usual levels of bad results.

1 Like

Unfortunately that is also my impression. That is why I am on the ball to have and maintain the “normal” running condition.

At the moment all devices, v1.4.0 and v1.4.1-rc.3 in the mix, run perfectly.

I realized sudfolder @eaDir was messing around and as it is useless just deleting @eaDir subfolders the problem was solved. Anyway the use of Synology NAS and Syncthing installed on it is a great solution for a small business in terms of eficiency and easy to mantain. Just finishing the tests to install Syncthing on our devices. Till the moment the results are quite impressive. Tnks all for your answers!

What is your meaning about messing and problems? I know the folder @eaDir as well and from time to time I delete with

find . -name @eaDir -exec rm -rf {} \;

It’s a good idea to add /@aeDir and /#recycle to your ignore patterns when setting up a new folder on Synology.

1 Like

I only have @eaDir without the / in the list, since this directory is sometimes also created in the subfolders. #recycle is a good idea, although I don’t use all the recycle bins in Synology’s shared folders.