Synology DS216play. Syncthing failed to run then disappeared from Syno Community Repo


#1

Hi there, I have been using syncthing on my DS216 play which I had installed from the Syno Community repo however after a DSM reboot yesterday the package failed to start when trying to run. I uninstalled the package and tried to re-install it however when I went to re-install it was no longer available to install in the package manager. I have tried adding and removing and re-adding the syno community repo several times and refreshing the package centre however is is no longer showing up. Has this platform stopped being supported or do I need to try and make my own package? (Never done before so should be a learning experience!)

Any suggestions welcome! Thanks in advance!


(Audrius Butkevicius) #2

We aren’t the ones packaging syncthing for Syno, it’s done by someone else. I suggest you get in touch with the community to ask.


#3

Ok will do thank you!


(Gabriela) #4

@Vinblastine, please keep us posted here when you receive an answer solving this problem, as this might be important for other Synology users, too. Thanks a lot!


#5

Just to update! I posted an issue on the SynoCommunity Git Hib with the fact that as far as I could see the package was actually completely missing when trying to find it on the package manager in DSM. I checked this on two disk stations that I own,a DS216play and DS214. I also noticed that there were a significant number of packages missing in package manager. The answer that I have received is that essentially that there are very few packages that have been updated to support DSM 6 and that most of them only support DSM 5.

Packages installed on DSM 5.2 remains in place after upgrade to DSM 6. As repository does not support DSM 6 yet, native packages are not visible for fresh install on DSM 6. Repository interface lacks a way to get direct download of a package binary… it may help in such situation so that manual installation may be possible

I find this very strange considering DSM 6 was released in March 2016!! Well over a year ago. Stranger still that I only installed syncthing about 2 weeks ago using the package manager from SynoCommunity! With regards to it failing to start again after reboot I suspect that this may be due to it being and unsupported package at this time. I have obviously been unable to replicate my issue due to lack of install :stuck_out_tongue:

At the moment had to work around the issue by installing syncthing on a networked debian pc and then have mapped my synology drives to that. Seems to be working ok! I suspected that I will try a manual install on DSM 6 if I can.

Link: SynoCommunity Git Hub issue


(Gabriela) #6

Thanks a lot, @Vinblastine! This is really not satisfying at all. I have also installed Syncthing last week and I am curious now what will happen after the next reboot/update of my disk station :frowning:. The workaoround with a Linux PC is no option for me, so I hope that they will solve this issue soon.


(Gabriela) #7

By the way, is there any possiblity to download a package which is installed on the Synology to your hard disk? As the syncthing package is still installed on mine, I thought I could simply download the installer package and then send it to you, but I don’t find any possibility to download it.


#8

I don’t think there is :frowning: I’m certainly no expert but I havn’t seen any mentions of it online. I think the package essentially self extracts and installs the program to /volume1/@appstore/syncthing. It also runs some scripts to generate the users and groups for the package.

I agree, not satisfying at all!


#9

As a work around you can “install” syncthing manually. I did that once for testing. Don’t have a Synology NAS at hand anymore to check if it still works that way. How to install Syncthing (arm release) on Synology?


#10

Thanks @wweich! I did look at your instructions earlier but had some trouble with them until I figured out that I needed to enable the home directories for my users! After that installed the binary into /usr/local/bin and then used the initctl script to make it autostart. Back up and running!! :smiley: Also feels good that I don’t have to rely on the SynoCommunity for updates. Also now have a working knowledge of vim which I didn’t have before!


(Nick Pyz) #11

Glad that the OP was able to find a manual workaround. However, I am curious if the following Syno DSM process was attempted, and if it failed:

(1) Open DSM Package Manager > Settings > General Tab, and select “Trust Level > Any Publisher”.

(2) Move to “Package Sources” tab, and add the Synocommunity repo: http://packages.synocommunity.com. Click “OK”. In the “Certificates” tab, you should shortly see Synocommunity’s RSA Key.

(3) Close the Settings and return to the main Package Manager screen. Scroll down to “Community” packages, and select it. You should see a lengthy list of packages in the Synocommunity repo, including (hopefully) Syncthing. Click to install.

If these steps are successful, you will no longer require updates from Synocommunity. Your initial installation may be an older version … but you should be able to execute updates within the Syncthing executable.


#12

I had indeed tried that however the packages were not available. I tried removing and re-adding the repo several times to see if that would re-fresh the packages. However with regards to a further update; I have updated my DSM to “DSM 6.1.3-15152 Update 4” which has just been released and all the missing packages from synocommunity have re-appeared and are available for install. I will test an install on my DS214 and will report back.


Need your help - Syncthing installation on Synology DS218+
(Gabriela) #13

@Vinblastine: everything fine now?


(system) #14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.