Syncthing v0.14.38, sender sync stuck at 0%, reciever folder "Up To Date" when it's not [SOLVED]


I am using syncthing v0.14.38 on a laptop and a server box, both on the same WLAN. Both machines are running UFW firewalls. Both machines are set to have port 22000/tcp and port 21027/udp open. Pretty much every other port is closed. The laptop (Ubuntu) is using the latest stable syncthing from git, and the desktop (Arch Linux) is using syncthing from the main repos.

Here is my UFW entry for the ports in question;

22000/tcp                  ALLOW            
21027/udp                  ALLOW 

Syncthing seems to start without issues, and my machines are able to discover each other via Local Discovery. They are also able to offer shared folders to each other successfully. This is using the Dynamic address option for both machines, and I have tried directly setting the local IPs and ports as well.

However, I am having trouble getting syncthing to do anything useful past there. If I restart both syncthing instances on each machine at around the same time, they will connect. I have a ~300MB send-only media folder on the deskop that starts to send, and my desktop shows “syncing” status for the target laptop, but it stays stuck at 0% with seemingly no data transferred. The laptop, however, claims its’ empty media folder is “Up to Date”, even though it’s not. After about 5 minutes, they will disconnect from each other again. Eventually they’ll reconnect again, but still no actual transfer occurs. This seems to repeat.

I was able to get my laptop to transfer a small test text file to my desktop at one point, but that’s about all I’ve been able to manage.

I seem to be getting a lot of output like this in the terminal for syncthing on my laptop machine; “connection reset by peer”, “use of closed network connection”, “i/o timeout”, etc…the desktop machine’s output is pretty similar. (note I attempted to delete and re-add the media folder):

[LAPTOP] 19:40:16 INFO: Established secure connection to [DESKTOP-ID] at 192.168.1.XXX:22000-192.168.1.YYY:42238 (tcp-server) (TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384)
[LAPTOP] 19:40:16 INFO: Device [DESKTOP-ID] client is "syncthing v0.14.38" named "desktop"
[LAPTOP] 19:40:16 INFO: Unexpected folder "media-folder" ([folder-id]) sent from device "[DESKTOP-ID]"; ensure that the folder exists and that this device is selected under "Share With" in the folder configuration.
[LAPTOP] 19:41:19 INFO: model@0xc42008b320 Adding folder "media-folder" ([folder-id])
[LAPTOP] 19:41:19 INFO: Ready to synchronize "media-folder" ([folder-id]) (readwrite)
[LAPTOP] 19:41:19 INFO: Connection to [DESKTOP-ID] closed: reading length: read tcp 192.168.1.XXX:22000->192.168.1.YYY:42238: use of closed network connection
[LAPTOP] 19:41:19 INFO: Completed initial scan of readwrite folder "media-folder" ([folder-id])
[LAPTOP] 19:43:22 INFO: Established secure connection to [DESKTOP-ID] at 192.168.1.XXX:42230-192.168.1.YYY:22000 (tcp-client) (TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384)
[LAPTOP] 19:43:22 INFO: Device [DESKTOP-ID] client is "syncthing v0.14.38" named "desktop"
[LAPTOP] 19:45:52 INFO: Connection to [DESKTOP-ID] closed: read timeout

I have fiddled with the settings and deleted/reloaded folders and such quite a bit trying to get the sync to work properly, but cannot seem to get anywhere. Advice on how to fix this would be greatly appreciated. Thank you.

EDIT: Actually, it seems to be working now. I think the issue was that I had some fairly heavy traffic passing through my network from my server while I was testing this stuff, and Syncthing wasn’t getting the consistent connection time it needed. I will update this thread if I notice any further issues, but my media folder appears to be syncing as it should be currently. [SOLVED] for now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.