Syncthing "Unavailable" on Mac OSX 10.14

On May 8, Syncthing stopped working on an iMac running OSX 10.14.6 (from which I cannot upgrade). But this seems to not be because of the update to version 1.27.7. In fact, I had version 1.6.1-1 until today and it was telling me for some time that it’s the newest version. I now manually replaced it with version 1.27.6-1 (latest that should work with OS 10.XX) via a dmg file and the problem persists. Interestingly, I have a Macbook Pro with Mac OS 12.7.5 and Syncthing 1.6.1-1 runs fine on it.

Specifics: At the top of the Syncthing menu it says “Unavailable” and then “Syncthing Service (Stopped)” in its submenu. The next submenu has “Start” but nothing happens when I click it. I can click other items in the menu but when I want to open the web interface, I get “Unable to connect, Firefox can’t establish a connection to the server at 127.0.0.1:8384”. Also, the “Unavailable” sometimes seems to flash something else, as if it changed to something and then immediately went back.

I’m not very computer savvy - I was able to set up Syncthing a few years back no problem, but here I have no idea what to do (tried restarting etc, of course). Any suggestions?

Thanks, Andrej

I suspect a discrepancy between the version of syncthing-macos (the icon thing in the menu that now says “unavailable”) and Syncthing itself (the core program that runs under the hood). Most likely Syncthing has auto upgraded, beyond what your system supports. There should be threads on how to disable this and downgrade with syncthing-macos.

Thanks for the suggestion but I didn’t find anything relevant and I did not find on my computer a file called syncthing-macos (I can only see the two versions of Syncthing.app: 1.6.1-1 and 1.27.6-1). I only found info about downgrading to 1.27.6-1, which I did using the dmg file and replacing the 1.6.1-1 version by 1.27.6-1 in Applications. Could you please give me a more specific pointer?

Yeah, that’s syncthing-macos; I realise the naming is confusing. I recommend following this thread: In MacOS High Sierra, Syncthing has stopped since 8th, May.

Thanks Jakob. I saw that page but something different is happening. I don’t have syncthing-bar.app anywhere, I also don’t have the ~/Library/Application Support/Syncthing folder, and I can see Syncthing in my Activity monitor. All this is the same on the laptop with MacOS 12.7.5 but Syncthing works there no problem. I tried to do on the iMac what that page suggests - disable auto-update through the terminal window and install Syncthing 1.27.6-1 via dmg but nothing changed.

P.S. I tried to download syncthing-macos-universal-v1.27.6.zip in case that does more than the 1.27.6-1 dmg file but I cannot run it (message: “syncthing” can’t be opened because the identity of the developer cannot be confirmed). Would this potentially help?