In MacOS High Sierra, Syncthing has stopped since 8th, May.

On 8th, May, Syncthing stopped by an error that the version 1.27.7-2 does not match with MacOS High Sierra, 10.13.6. It seems that the problem is auto-upgrade system. I tried to stop the auto-upgrade system from the command line with “defaults write com.github.xor-gate.syncthing-macosx SUEnableAutomaticChecks 0” and downloaded “Syncthing-1.27.6-1.dmg”. I installed “Syncthing-1.27.6-1.dmg”, however, it does not work with the following error message. (I am using “syncthing-bar” which I installed long time ago.)

I guess “Syncthing-1.27.6-1.dmg” does not match with MacOS 10.13.6 “High Sierra” because this error message saying, “you need to confirm the developers that this “syncthing” works in this macos version. you may need to re-install in case” in Japanese. I am searching a lower version of Syncthing. It may be 1.26, 1.25. But, I cannot find them out. I need your kind helps.

Process: syncthing [22532] Path: /Applications/syncthing-bar.app/Contents/Resources/syncthing/syncthing Identifier: syncthing Version: ??? Code Type: X86-64 (Native) Parent Process: syncthing-bar [22531] Responsible: syncthing [22532] User ID: 501

Date/Time: 2024-05-11 07:16:31.164 +0900 OS Version: Mac OS X 10.13.6 (17G14042) Report Version: 12 Anonymous UUID: A427B280-184C-0EC2-D1D2-8617C9789D09

Time Awake Since Boot: 77000 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT) Exception Codes: 0x0000000000000000, 0x0000000000000000 Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: DYLD, [0x9]

Application Specific Information: dyld: launch, loading dependent libraries

Dyld Error Message: cannot load ‘syncthing’ (load command 0x80000034 is unknown)

Binary Images: 0x102303000 - 0x103092ff7 +??? (0) <8B2E323E-8012-3913-B8F8-95A2D26F3B29> (null) 0x111384000 - 0x1113ceadf +??? (551.5) (null)

Model: iMac17,1, BootROM 428.0.0.0.0, 4 processors, Intel Core i5, 3.3 GHz, 24 GB, SMC 2.34f3 Graphics: AMD Radeon R9 M395, AMD Radeon R9 M395, PCIe Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1867 MHz, 0x80AD, 0x484D54343531533642465238412D52442020 Memory Module: BANK 0/DIMM1, 8 GB, DDR3, 1867 MHz, 0x85F7, 0x48363431475536374733313836470000 Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1867 MHz, 0x80AD, 0x484D54343531533642465238412D52442020 Memory Module: BANK 1/DIMM1, 8 GB, DDR3, 1867 MHz, 0x85F7, 0x48363431475536374733313836470000 AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x14A), Broadcom BCM43xx 1.0 (7.77.37.33.1a1) Bluetooth: Version 6.0.7f22, 3 services, 27 devices, 1 incoming serial ports Network Service: Ethernet, Ethernet, en0 Network Service: Wi-Fi, AirPort, en1 Serial ATA Device: APPLE SSD SM0128G, 121.33 GB Serial ATA Device: APPLE HDD ST2000DM001, 2 TB Serial ATA Device: HGST HDS724040ALE640, 4 TB Serial ATA Device: HGST HDS724040ALE640, 4 TB USB Device: USB 3.0 Bus USB Device: Bluetooth USB Host Controller USB Device: FaceTime HD Camera (Built-in) USB Device: Magic Keyboard with Numeric Keypad Thunderbolt Bus: iMac, Apple Inc., 28.1 Thunderbolt Device: G-RAID with Thunderbolt, G-Technology, 3, 26.3

https://github.com/syncthing/syncthing/releases

Also see: https://forum.syncthing.net/t/1-27-2-2-broken-on-macos-10-13-6/22110/2

You need to remove syncthing-bar and install Syncthing for macOS v1.27.6-1. Probably Syncthing bar auto-updates syncthing and breaks.

Thank you very much for your kind advice. I removed syncthing-bar and installed v 1.27.6-1. However Syncthing does not start up with no error messages. I checked if syncthing is working or not with “Activity Monitor”, and did not find any process of “syncthing”. Do I need to uninstall “syncthing” before install 1.27.6-1. I welcome any comments about this. Thank you very much in advance.

Syncthing for macOS starts as an icon in the tray. There is no welcome screen. It should start and be visible in “Activity monitor”.

Thank you for posting this fix as well as the link to an earlier version. Syncthing 1.27.2 also broke the app in Mojave. I have removed the inoperable version and installed 1.27.6-1 and it’s working again. BUT I can’t seem to find syncthing-bar anywhere on my computer. I’d like to remove it to prevent auto-updating. In what directory will I find syncthing-bar?

Thank you very much for your kind advice. I moved /Apprications/syncthing-bar.app to ~/.Trash and opened /Apprications/Syncthing.app, which I downloaded for “Syncthing for macOS [v1.27.6-1]”. However, I cannot find any process of “syncthing” in “Activity Monitor”. And the page “http://127.0.0.1:8084” is not active.

At present, I found the automatic upgrade system was not killed by the command “defaults write com.github.xor-gate.syncthing-macosx SUEnableAutomaticChecks 0”, or removing “syncthing-bar” in /Applications/ folder. I found this fact by the terminal command “open syncthing-macos-amd64-v1.26.1/syncthing”, which is included in downloaded “syncthing-macos-amd64-v1.26.1.zip” At that time, “syncthing” worked properly only for one minute as I confirmed it in Safari. The page is “http:127.0.0.1:8084”. At the top of the page, a message like “Soon it is upgraded to 1.27… in one minute”. Somehow I cannot reproduce the display again.

You are using the incorrect Syncthing. You need the https://github.com/syncthing/syncthing-macos/releases/download/v1.27.6-1/Syncthing-1.27.6-1.dmg this also creates a icon in the tray. You can enable automatic start at login from Preferences. The icon application ships syncthing commandline and it disables auto update of syncthing itself. You don’t need to use commandline at all.

Thank you very much for your kind reply. I appreciate it very much. However, Syncthing-1.27-1 does not start up in my iMac (High Sierra, 10.13.6).

  1. I deleted “syncthing-bar.app” and “Syncting.app” in the “Applications” folder.
  2. I downloaded “Syncthing-1.27.6-1.dmg” from the link you suggested, and opened the dmg file, and move “Syncthing.app” to the “Application” folder.
  3. I opened “Syncthing.app” and got a security message, and allowed it. Nothing happened. No process of “Sync” appeared in “Activity Monitor”. The page “http://127.0.0.1:8384/” does not appear.

Recovering by “Time machine” does not help because the auto-upgrade system of “Syncthing” works every time when I log in.

I got new information.

I repeated the same procedure again after removing ~/Library/Application Support/Syncthing.

This time I found a process of Syncthing in Activity Monitor for one second. The process disappeared as just one second has passed. I cannot get any error message when I started up “Syncthing”.

Finally, I have successfully installed “Syncthing v1.27.6” by using “macports”. It is a downgraded version of Syncthing v1.27.7-2. Syncthing started up automatically by ~/Library/LaunchAgents/syncthing.plist, which is copied from /opt/local/share/examples/syncthing/syncthing.plist.

Now automatic upgrade system is disable.

All the connections with other PC’s are recovered by copying back folder “~/Library/Application Support/Syncthing”. Icon of Syncthing does not appear in the top menu bar of High Sierra display.

This may not be an ideal solution, it works at least. I thank all folks for giving me precious advices and time.

1 Like