Syncthing stuck at Syncing 99%, Out of sync items


I have very strange problem with syncthing. I have installed it on 2 PCs, let’s say on server and on a computer. So on server I have all folders and computer device are up to date. But on computer syncthing stuck at 99% with 2 out of sync items (this is MS office docx files). So 2 important files just don’t sync!

This is computer:

This is server:

What’s wrong with Syncthing?

@SuberSeb, welcome to Syncthing!

From your screenshots it is not clear where the files are located because you blacked out the folders names. Also scanning is currently in progress. General problems during sync are file permissions, access problems if files are locked, etc.

It would also help if you can recreate the problem for easier bug tracking.
Is Syncthing creating a temporary file at target or is nothing happening at all? What happens if you put the same files in different folder? Or try putting the files in a new Syncthing folder for testing.

First screenshot is server, second one is computer. Problems only with the third folder.

Not sure why this happens and how to reproduce that issue. I worked with MS Office files for a couple of hours, sync was fine. But now I noticed that files I worked on not the latest version. Even if I put new file, it’s just don’t sync from computer to server. Sync is just stuck.

Syncthing tried to sync temp MS Office files (with “~” symbol in name), so I added in to ignore patterns. Sync still don’t work.

Added file in my folder, let’s say test.txt with some random text in it. It’s don’t sync, again Out of sync problem.

I too have been trying Syncthing on several devices and I get nearly always the same sort of issues (99% sync with a few files not syncing). I wonder if you have encountered the same issue as myself. Please try go into Remove Device on EACH computer, un-share the problem folder and Save. Go back into Remove Device and re-share the problem folder and Save. This fixed the issue 100% for me and I’ve not further problems since with files syncing. I have had to do with for every new device I’ve set up, whether that is a Linux PC, Windows PC or even Android device.

1 Like

As the folder is scanning in your screenshots and it’s docx files: Do you have word open? That may lock the files (Syncthing can’t open them) or they may change before Syncthing can sync them. If that’s not the case, can you please expand the problematic folder and take a screenshot when it is not scanning.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.