*.syncthing.net sites inaccessible when strelaysrv is listening on port 22070

Just a disclaimer, this is basically a continuation of https://forum.syncthing.net/t/errors-when-trying-to-run-strelaysrv-for-the-first-time/16818.

I have now found some time to do more testing trying to investigate what exactly the culprit may be. It seems that opening the port 22070 for strelaysrv results in all sites, such as https://relays.syncthing.net or https://apt.syncthing.net becoming inaccessible from my network. However, if I use a different, random port instead of 22070 (e.g. by using UPnP), then the issue doesn’t occur, and the sites remain accessible. The problem with using a different port is that no stats are displayed on https://relays.syncthing.net, yet the relay server itself remains functional.

Do you have any idea why opening the port 22070 could cause the above to happen?

Some thoughts:

  • Default port for the relay server is 22067, not 22070?
  • It’s perfectly fine to run the relay server on a different port and still show up on relays.s.n, see the relays running on 443 for example.
  • relays and apt s.n seem to be both hosted on the same VM (web.s.n), but forum.s.n and syncthing.net are not.

The reason for these strange issues really seem to be some weird issues with port forwarding. When you host a relay server, the pool server tries connecting to you to check connections. This apparently really breaks your networking with that host for some reason. This may be due to an issue with your network configuration, or bugs with the router’s software.

It uses both. 22067 is the “protocol listen address”, and 22070 is the “status service listen address”. From what I can see, there are no problems if I open 22067 only. I have tried with UPnP, and now I’m just running

strelaysrv -ext-address=:443

with 443 being forwarded to 22067 on the router to the server. On the other hand, 22070 is available only locally right now, with no forwarding set on the router. In this configuration, there are no issues accessing the sites, and the server itself is also working fine.

This is true, and the server is shown there right now, but with no stats (“data transferred, number of clients, etc.”), which are only available if 22070 is open. With the port closed, it just shows “data unavailable”.

This is very useful information. The forum indeed works, and I forgot to add that https://docs.syncthing.net worked too.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.