Syncthing Killing Phone Connection/Calls - Android 10

Been fighting an issue for a couple weeks and finally figured out it was the Syncthing client on my Pixel 3. This all started after updating to Android 10 release (I was running the 10 betas from beta 3 on, with no issues until the actual release).

When Syncthing is running, it kills my phone connection within about 15 seconds of starting. The notification icon for call signal drops to 0, with an x indicating no signal. This causes dropped calls and prevents calls/SMS from coming in or going out; it only affects call/SMS signal, mobile data is unaffected. Have confirmed this is actually interrupting call signal, not just an indication issue. Have confirmed on multiple WiFi connections and multiple carrier tower locations.

This happens only when Syncthing actively runs, meaning if Syncthing is only set to run on WiFi, then when I connect to WiFi, it interrupts the call signal. If run rules configured to allow mobile data, same thing. The phone connection will reconnect within about 15-30 seconds once Syncthing is killed or stops (i.e. if stopped by run rules).

What hasn’t worked:

I’ve attempted multiple restarts, multiple resets of network settings, multiple reinstalls of client, updating to the latest client 1.3.0rc2 beta, cache and storage clears, using Syncthing-fork app, and extensive searching of the forums for similar items, all with no luck. Suspect a factory reset may be next.

Looking for some troubleshooting help.

Thanks in advance.

System Details:

  • Phone: Google Pixel 3
  • OS: Android 10 (Build QP1A.190711.020.C3)
  • Syncthing Version: and beta 1.3.0rc2
  • Carrier: Visible Wireless (MNVO of Verizon Wireless, USA)
  • Carrier type: CDMA/4G LTE

Steps to reproduce:

  • Open Syncthing app / Start Syncthing running
  • Call signal drops within approx 15s.
  • Call signal may reconnect briefly after approx 30s but will drop again shortly thereafter; this will repeat indefinitely
  • calls/SMS cannot be placed or received
  • kill / stop Syncthing
  • call signal reconnects within approx. 15s and stays connected

Sorry, but this should not be possible, the fact that it is points to a problem with the phone/OS, as no software should be able to do that.

I agree it will probably end up being phone/OS caused, but it’s definitely triggered by Syncthing. I’ve been trying to track it down for weeks, uninstalling quite a few apps till I finally figured it out.

It doesn’t happen in safe mode (should have mentioned that above). Wondering if maybe something odd happened with the app optimization after the update?

Any logs I can pull to try to track down what might be triggering?

I’m resigned to a factory reset if needed as I suspect that may fix it, but wanted to see if may be something happening behind the scenes.

Well, syncthing does not do something on purpose to disable your mobile reception.

I’m sorry if it came across that I was suggesting this was purposeful; I understand it’s not and I hope I didn’t offend. I was not complaining; Syncthing has been great. More I was looking to see if there was something more going on that I was missing.

If my previous troubleshooting attempts have already hit the possible problems points, and there’s nothing more that can be suggested, I’ll try the factory reset.


To have a light start I think capturing an Android log, e.g. via ADB logcat, makes sense as I suspect Android OS services and/or drivers, firmware may cause the described behaviour. If that’d be the case, the log should mention Warnings or errors pointing to who is responsible. It could be google, the go native Environment, SyncthingNative or (which I expect least) the wrapper.

Fwiw, I’m on Verizon with a Pixel 3 and the exact same Android 10 build. No issues with Syncthing since the update and syncing around 10gb. Sounds like a factory reset would be a good idea, as painful as that can be.

Will do - traveling yesterday, but will make time later today to get the output from logcat.

@firecat4153 - thanks, that’s one more data point saying it’s probably only an issue on my end; factor reset seems likely.

Here you go.

logcat2.txt (1.3 MB)

Running a 3XL tried the launch 10 build and the October security updates, works as expected. Definitely something relating to your phone.

@youngheart80 I’ve sat ~ 15 minutes over the log, but I’m clueless what caused the disconnect on your mobile adapter. Generally I’ve found:

  • The log is full of Errors and Debug lines (E/D)
  • It mentions “waste RAM, bad performance” on multiple lines - not sure if that is critical or just a “NOTE” as stated on that lines.
  • AppOps denies some permissions and affects Synchting’s BootReceiver. Anyways, technically the apps should still work okay when autostart is denied.
  • I’ve noticed a lot of apps present on your phone (tools, games, etc.) - can’t say if it is too much as your phone model looks pretty much like a flagship having enough system resources.

Eh, it was a longshot anyway. Thanks for looking. I know what I’ll be doing for at least part of this weekend.

Thanks again.

1 Like

All, didn’t realize there was a split-off communication I was having with @Catfriend1 regarding troubleshooting this issue where we talked about this, but wanted to post the results of my factory reset last weekend.

It did not fix the issue, unfortunately. Even on a fresh factory reset, the same signal drop was present.

As my SO has the same phone model and the same service with Visible Wireless, I thought I’d check to see if her’s would have the same result. Turns out, it does - same signal drop, same pattern as before.

So, this seems to be either some weird mix of Syncthing, Pixel 3, and Visible; or something that Visible is causing on their side of things that Syncthing somehow triggers.

As of now, my only way to really deal with it is to only run Syncthing when I have some specific reason and then kill the app after I’m done.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

@youngheart80 Can you try disabling Local Discovery in Settings - Syncthing Options? I also experience cell disconnects with the same carrier and similar phone (Pixel 3 XL):

Presumably the local announcement packet triggers the cell disconnect, either by the phone (OS or kernel bug?) or the carrier (Visible/Verizon). However, I was not able to trigger a disconnect when sending IPv4 broadcast and IPv6 multicast from Termux:

echo -n hello | socat - udp-datagram:<cellular link broadcast address>:21027,broadcast
echo -n hello | socat - udp-datagram:,broadcast
echo -n hello | socat - udp-datagram:[ff12::8384]:21027

@firecat4153 when Syncthing is active (satisfies run conditions) and local discovery is enabled, does your phone briefly downgrade from LTE to CDMA every minute or so? If so, Verizon has the same issue, but Visible only operates on LTE, so the phone won’t seamlessly downgrade to CDMA.


I’ll need to do a bit more playing once I get home to Wi-fi and have my other devices up, but yes, disabling Local Discovery does seem to solve the drop issue. I want to say I tried that setting on a previous build, but it caused the app to crash immediately. I’ll also admit I had given up hope of anything getting done and so have migrated away from using Syncthing, but if this gives a direction that might help fix things, I’ll be back in a heartbeat - Syncthing did exactly what I needed right up to the point where Android wasn’t working.

Let me do a bit more testing in a couple of hours once I’m away from work.

@dara, many thanks.

I have been working with it for the last hour, re-setting up my folder shares. Everything works perfectly. No signal drops, no issues. Disabling Local Discovery does seem to have addressed the situation.

It would be interesting to see if @firecat4153 or another Pixel 3/3XL user on Verizon can chime in to see about the drop from LTE to CDMA.

I’m not aware of any drops to CDMA from LTE (Verizon). I have Syncthing set to run always on Wifi. I’ll usually turn on a wireguard VPN when on an outside Wifi source, but not when I’m home. I believe my Pixel 3 is setup for Wifi calling, so I’m not sure if that changes anything. I did switch Syncthing today to run also when on mobile data and didn’t notice any service drops. I have local and global discovery enabled, but relaying disabled.

In all fairness, I’m only measuring service drops by looking at the notification bar display. If there’s a different/better way to check that, I’m happy to try.

@firecat4153 @dara

Could you please post which Android versions you are on, is it also 10 like @youngheart80 reported?

I’ve had a chat with him and we we are trying to narrow the issue down to a specific hardware and/or software constellation.