syncthing change folder path on target computer

Hello Everyone,

I have One source computer at home on my private network connected to an external drive. I have a Target computer at my friend house connected to an external drive.

Is there is a way to select the location of the drive in Client PC so like this pc 1 and pc 2 both are 100 % Sync.

i am playing with syncthing at home with 2 different computers and this option is not available or i am doing something wrong. On Client /Target computer the default location is C:\Users\Admin\Sync and i created a test folder when it synced it went to C:\Users\Admin\TEST

I want the location for Target pc hard drive to be external drive

Please advise

Thank you very much in advance

Hi,

Just set it to D:\ and ignore some system folders you don’t need.

1 Like

First, make sure you have auto-accept off. Then, when accepting a new shared folder on the remote machine, the GUI-dialog offers you an option to set the folder path, just like you can do on the sharing machine.

1 Like

How don’t see that options anywhere. I am using Windows client

I can try that but I haven’t seen that option when adding the client PC. Also I was not able to find any options to set main computer vs client PC Thanks

You can specify a path when adding a folder.

1 Like

Hello When i go to source computer YES i am able to select a folder from D Drive but on Target pc i am not able to select folder in D drive it auto select it for me. i disabled auto discovery. i am using windows 10 for both computer and i am using SyncTrayzorSetup-x64 i dont know if that matters but it is an .EXE file that got installed

I do see syncthing as application but i haven’t run it or did anything to it

Please advise and thank you everyone for kind reply

You can create a new folder on each side at whatever path you want, just make sure the folder id is the same.

1 Like
  1. In the GUI, on both sides, select the other device in the GUI (lower right) and press the Edit button below the device. On the popup-dialog, switch to the Sharing tab and make sure Auto Accept is unchecked (at least on the receiving side, but to double check: Have it off on both computers).

  1. Then, share a new folder with the other device. The other side will show a dialog, asking you to accept the share.

  1. Accept the share by clicking Add. A new dialog will popup, where you can select the folder path on the local machine. That text field is editable, but there is no “browse” button: You have to type in the folder path manually (or copy-paste it). For example, you might want to replace the default C:\Users\user\example with D:\myfolder

2 Likes

Hello

It worked now i am able to add External drive folder on both side

Thank you very much all and Nummer378 for screen shots

Thanks

1 Like