Syncthing-Android v0.7.0-beta2

This finally gives us Syncthing v0.12. Additionally, Gingerbread will no longer be supported. And thanks to @veniosg for his rework of the app design.


  • updated Syncthing to v0.12.0-rc5
  • raised minimum SDK version to 11 (Honeycomb)
  • raised target SDK version to 23 (Marshmallow)
  • lots of design improvements (@veniosg)
  • added confirm dialog for config import/export (@nutomic)
  • only ask for root permissions when the setting is changed (@nutomic)
  • fixed inefficiency in inotify (@nutomic)
  • imported translations

Download from Github

The beta should also be on F-Droid soon.


Does this replace the old one? Will it use it’s config by default or at least import it, HowTo upgrade,…

Yes, it replaces the old version, and use the existing config automatically.

Updates to new beta versions can be done from F-Droid or Github. Updates to release versions from F-Droid or Google Play. Note that F-Droid APKs are signed with a different key, and can’t be installed directly over Github/Google Play APKs.

Where should I send bug reports? I installed on both my android devices, updated desktop version to latest 0.12 build and it looked fine. Tryed using relays (connect and sync through 3G network of one of the devices( which did not work before)) and it worked. But after some hours both devices have strange behaviour. On S5 syncthing works (copying file to synced folder sends it to PC) but Syncthing-androiid crashes on start(even after a phone restart). On S3 (running latest CyanogenMod) Syncthing-android works until I select “settings” and then it crashes. Any hints and how can I help track this problem?

try it here

@Nutomic Could you upload some Screenshots of the new UI? Sounds like there are some significant changes :smile:

0.7.0-beta2 is out, changes:

Download from Github

1 Like

Thanks, it works now on both devices. Could you change the topic to reflect that there is a new beta - something like Calmh has done with the RC?

Trying today, seems a bit slow to start, sometimes syncthing connects to others and wrapper still shows “loading”, but after a while (much longer than old versions) it starts.

In “devices” all shows “up to date” immediately after first connects to it, even for those who are not running, also when showing “syncing (xy%)” its same for all in device list (will create issue for this).