Synching Windows / Linux doesn't work bidirectionally

I’ve got a Linux box acting as a file server to my intranet. It does so featuring a couple of samba shares. A couple of Windows-7 boxes connect to the file server without a glitch.

On my brand new laptop I’ve got a dual-boot configuration with Windows-7 and Linux (Kubuntu). Accessing the file server on both os’s reveals no single problem.

For offline work I’d like to mirror parts of the file server to my laptop. Therefore I have an NTFS disk partition called “Server Mirror” (I know that it has been a bad idea to have a space in this name, but I can cope with that). So I use Syncthing to have my local disk on the laptop synchronized (bidirectionally) with the counterpart on the file server.

Everything works fine on the Kubuntu side. With Windows, every mutation on the file server’s side gets mirrored to the local server mirror as expected. But no single mutation (creation, modification or deletion) of files on the Windows side makes its way back to the file server :frowning: . Syncthing on Windows seemingly does not take notice of any mutation.

As far as I as a Syncthing novice can tell, the configurations on both sides are identical.

What can I do to make things work? Which additional information is required to get help? Any hint will be appreciated. Thank you in advance.

Screenshots on windows would help

Which ones? I could offer screenshots of GUIs, folder options etc. What would help most?

Update: An hour ago, I upgraded to v0.12.1. Since then, things went worse. I have to investigate more, but I suspect that modifications from the laptop to the server work no longer even on the Kubuntu side.

Only one of your folders is actually shared.

Though item counts match, which implies in sync.

Yes, right, this is intended. At the moment being, I indeed share only the folder named “abacus-fs.I”, in order to keep scan/update times as low as possible while testing. I will supply another set of screenshots showing the differences between the file server and laptop.

Here are another two screenshots. The first one shows the state of a temporary directory directly grabbed out of the file server:

The second one shows the state of the same directory on my server mirror located on my laptop:

The file “AnotherServ2Lap.txt” has been created on the file server and gets almost immediately replicated to the Windows box.

The file “AnotherWinLap2Serv.txt” has been created on the Windows box. The file “WinLap2Serv.txt” has been modified on the Windows box. None of these modifications get synchronized to the file server.

On the other hand, deletion of two other files on the laptop did get synchronized, contrary to my earlier statements.

Odd. Are you sure it’s not the network share view that is out of date/cached?

As far as I can tell, yes. As long as I stay on Windows, no syncing happens from Windows to file server, not in hours, not in days.

Shutting down Windows and starting up Kubuntu immediately makes Syncthing work as it should. Both os’s work on the same shared NTFS partition. Back to Windows: no luck at syncing from the laptop partition to server.

I tried tinkering with access permissions. Meanwhile, both configurations of the folder have the “ignore permissions” flag set. I even opened up the Windows partition’s file permissions to be fully accessible for everybody, to no effect whatsoever.

Any other ideas where to look, what to try? Thanks for the replies so far.

Are you saying the count of files syncthing reports doesn’t match whats actually on disk? If it does then it should not match the global state and should look out of sync. If it says its in sync, then either it hasn’t received an update for the new file, or its actually got the file there.

Once you add the new file and its not there, take a screenshot of web ui from both sides

Are you running both of these on the same computer, dual booted? Shared config & index? Something sounds weird here…

Yes, that’s what actually is happening. Windows just doesn’t notify Syncthing of any mutations.

You can look at the screenshots I provided earlier, they show what is happening pretty good. At your request, I’ll repeat the scenario. Screenshots will get posted later.

Yes, the laptop is dual-booted. Configurations are apart. Where are the indexes located so I can check?

With the configuration. This is a potentially confusing setup for Syncthing, as the index will say it has downloaded a certain version of a file, you’ll reboot to other OS, and it’ll detect the file as changed compared to it’s older index information. I’m not sure whats going on here exactly, but I think this may be related.

Screenshots from both GUIs (Linux server and Windows laptop) before creation of new file:

Creation of a new file “1511080824 Serv2Lap.txt” on the Linux server. This one gets immediately replicated on the Windows laptop.

Creation of a new file “1511080826 WinLap2Serv.txt” on the Windows laptop. This one does not get replicated to the server.


The resulting GUI screenshots after a few minutes:

Once again: Thank you guys a lot for your terrific work and responsive support!

Meanwhile I checked this issue. According to the documentation, configuration and indexes are stored below %LocalAppData%/Syncthing on Windows 7 and $HOME/.config/syncthing on Linux, which is the case on my laptop. These locations are strictly kept separate (on different partitions).

Both Syncthing installations share only the partition for the data to be synchronized.

Sorry, but you added a file, and the file count on both sides increased, so as far as syncthing is concerned, it did its job. I suggest you look for problems otherwise.

Perhaps explorer is showing you and outdated list of files, and you need to refresh

No, it did not.

As far as the synchronization part of Syncthing is concerned, ok. But it fails on detection of changes on the Windows side:

The directory in question contains 7 files on the Windows side and 6 files on the server side. You can make that also up from the earlier screenshots.

Once Syncthing detects mutations, they get handled well. And that is what you see in the GUI, from the Syncthing point of view everything looks good. But how can I see on what events Syncthing does or does not react in order to catch the changes?

So syncthing on Windows fails to detect changes in files or new files created while scanning, but detection of deleted files works fine? I presume you tried manually hit rescan button (although you have 60s rescan interval). This sounds super weird…