Sync over "ethernet" only (actually over USB)


Sync over “ethernet” only (actually over USB but the connection show up as an “ethernet connection” on Ubuntu


I am VNC’ing into my laptop from the phone. Somewhat unusually I’m using a USB cable for the connection.

I have syncthing running on the phone and on the laptop.

I want to set sync to local only as I have to pay for Internet per MB. I. e. I don’t want syncthing to sync over internet, just over the USB cable.

Is there a way to do this?


Samsung Galaxy 5

Laptop running Ubuntu 15.10


If the connection between the two devices shows up as a network card or something similar you can block syncthing to go on “internet” using a firewall so to restrict it to be able to reach only the IP of the other device.

(Jakob Borg) #3

Or set device addresses manually, or use device allowed IP ranges, or disable global discovery, all depending on what your setup actually looks like…

(system) #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.