Sync often stuck at fixed percentage

Hi all,

How can I easily tell which files are stuck or which are sync’d?

Here is why: I am running syncthing 0.14.12 on windows 10 (SyncTrayzor), ubuntu 16.10 (Syncthing-GTK), and mac (syncthing-macosx). The addition of the osx machines led to all kinds of “.DS_Store” file conflicts (as one would expect) so I added these to the .stignore file (and put this .stignore file in all archives of all computers). No conflicts since. However, since then, the sync keeps stopping at a fixed percentage: often 100%, often 95% or 67%. I have never had a version earlier than 0.14, so the index shouldn’t be the problem (and clearing it doesn’t help).

Thanks! Jack

This is an expected side effect of ignored files, as other peers have files you refuse to download.

Thanks, that’s what I was presuming, but is there an easy way to see which files are synced and which have issues (i.e. to make sure this is just the ignored files and not something important)?

Open the web UI and have a look at the list of out of sync files.

I am getting the same sticking percentages on three of my six machines, both on the same network and remote. It seemed to start happening about two releases ago, v0.14.11 I think.

In the web UI there is no list of out of sync files for any of the machines.

The out of sync files are displayed per folder.

Some screen shots might help but if the folders are all up to date but the devices aren’t it is probably ignores.

I have attached 3 screen shots. The other machines in the group are showing fully synced. As a new user I have to send them individually.

You should check the remote device as to why its out of sync.

1 Like

I think there is an actual bug here. I can reproduce the 95% case - it’s 100% after Syncthing restart, then 95% on the next and following GUI reloads. I think it’s a GUI/events issue.

So if the local and global file counts are the same, there are no worries, correct?

When they aren’t (and the “local” number is lower, saying “reduced by ignore patterns”), is there a way to see the list of files that are out of sync, to verify it’s just the ignored ones?

I’m particularly concerned about the reduced number of folders, since no folders should be ignored. Need to troubleshoot :slight_smile:


Sorry for the delay; many computers at many locations to troubleshoot. It turns out that if even one folder on one computer has a slightly different .stignore file, then this behavior appears. There was a bug in one of mine.

On the other hand, if all have the same exact .stignore file, I find the global and local states are identical and everything appears green, happy, and reassuring. Great!

Would it be possible to add a checkbox for “synchronize ignore patterns” in each folder’s options? I think having all computers ignore the same file types would be a very common goal among most users. I’d even go so far as to say it should be checked by default (or you could simply require that the user add “.stignore” to their .stignore file to prevent these from syncing).

Cheers! Jack

PS- I also still think that the UI should somehow indicate that all files that should be synced are synced; currently it is impossible to tell that everything is actually ok without traveling to the other computer.

I use a global ignore file that is linked and synced… Have a look at:

1 Like

Thanks! I considered your solution awhile back – it still requires that I edit every folder on every machine – but since my ignore patterns are so simple it was just as easy for me to update all the folders in the normal way.

This does bring up one more (also easy to program) solution: if syncthing checked for two ignore files (e.g. .stglobalgnore and .stlocalignore), one of which was synced across devices by default, then it would be straightforward for users to set up either / both methods. The simplest UI modification would be to have either a second button/dialog for global ignores, or two text boxes in the existing ignore dialog.

This is a solved problem. Read the docs.

Um, I had. Are you referring to the .stignore docs? In there the only solution I saw was to manually add a #include to every folder on every computer when first setting up, as was discussed above in this thread (and the other thread it pointed to).

I am only suggesting that a global ignore behavior is somehow the default / built into syncthing’s user interface. This is obviously a value call, and I’m not that attached to it now that I’m used to syncthing. However, it is not terrible to implement and might make life slightly easier for new users; everything that lowers the bar for entry increases the user base and the momentum of the project. For me, synctrayzor was the thing that finally pushed me past threshold to try this out; it is scary to change sync platforms. :slight_smile:

I have also been operating under the assumption that feedback from new users like me might be useful for you folks. I am happy to just quietly live with the quirks if you like (it’s less work for me). I realize there is an overwhelming list of suggestions at this point.

It’s not a reasonable default, as it has security implications (you can unignore what others chooseto ignore). Given you’d have to click something in the UI to enable it, it’s of an equivalent value just to add the line in the ignores. Yeah, we could advertise the feature more, but the microns of optimist in me hope that users read the manual when they want something they can’t find immediately.

Fair enough. Presumably when the ‘confusing’ effects of adding device-dependent ignores is clear in the future version (as per the comment on that manual page), most of the need for this behavior will dissipate.

I am now also reminded that perhaps some people use this system for things other than personal sync / backup, like sharing with other people. :slight_smile:

Is the stuck-at-95%-bug already being addressed? I have too it on several devices trying to sync with my phone.