Stopping folder - path exists, but folder marker missing

Hi,

I have Syncthing running on Ubuntu 14.04, Windows 8 and Android. So far I’ve only synced one folder (with several subfolders), no problem so far. Syncthing v.0.10.21

Today, I got the error message: "Stopping folder “default” - path exists, but folder marker missing. All I had previously done was that I added some files to the sync folder before starting the demon via Syncthing GTK.

I got the error running Ubuntu first, then I tried Windows, with the same result. I did some searching and read something about adding a “.stfolder” file (empty) to the sync directory. I called it “syncthing.stfolder”, but it hasn’t changed anything. Maybe I misunderstood something. Anyway, if Syncthing wants that marker, it should have created it itself, shouldn’t it?

Any ideas what I could do? Thanks.

1 Like

Well it creates the marker at the point you add the folder.

If later the marker disappears we assume there was a mount issue and not sync that directory, as in case of a mount issue syncthing would see all files as removed, hence user intervention is required to resolve this issue.

The file is literally supposed to be named .stfolder. I am not sure you can create this from Explorer on Windows.

1 Like

If you (accidentally) deleted this file, you can open a command line window and enter

type nul > "c:\path\to\your folder\.stfolder"
3 Likes

Thanks, that did it!

I tried creating a file “.stfolder” via the Windows Explorer, but of course that did not work. As the sync folder was on an ntfs partition that can be accessed via Ubuntu, I could simply create it with the Ubuntu file manager. Thanks.

1 Like

Maybe syncthing should create this on start if it’s missing.

If we were to do what you suggest, then there is no reason to have it all…

There’s a reason why it’s there, which is to identify mount issues, so that when a mount fails, we understand that it’s the mount that has failed and not user deleted all files, tell all nodes to delete theirs.

1 Like

These steps seem to work for me in Powershell

$temp ="" $temp|sc path.stfolder

This worked fine for me. The GUI showed the folder as stopped and the error was “folder marker missing”. This command re-installed the missing .stfolder and then syncthing resumed syncing that folder. So far we have been very impressed with syncthing.

If you tell Explorer to create .stfolder. (with the trailing dot), it will in fact correctly create .stfolder

4 Likes

Fun fact - that works because you can’t have file names with a trailing dot on Windows.

(I’m sure actually trying to sync a file called foo. from Linux to Windows will result in hilariousness as we don’t take care to handle that specially.)

1 Like

what is the problem with “foo”?

It’s foo., not foo

So what is the problem with “foo.”? probably googling it will help but the joke is funny only at the moment…

“Hilariousness” = “everything breaking”

I understand now. You can have files with trailing comma under Linux but since it is not possible to have such files under Windows the things will probably break… So another edge case that should be taken care of :slight_smile:

Actually, I think that’s an Explorer and not an NTFS limitation. I just succesfully created a foo. file in cygwin and it shows up in explorer as expected.

Given that, I created a foo. on Linux and had it synced to my Windows 10 box, it works as expected. Explorer doesn’t like the file (i.e. renaming it doesn’t work too well, without removing the trailing .) and I didn’t check what would happen if I tried to feed it to various programs, but at least the file itself synced as expected.

EDIT: Well, good question what would happen on any of the FAT versions…

1 Like