SteamDeck - No .stfolder when creating folders with in ~/.var

When trying to sync my retro arch saves in .var/app/org.libretro.RetroAch/config/retroarch/saves a .stfolder folder hasnt been created there when i have retro arch create a files there, they don’t get synced then eventually after restarting the deck or something it says “stopped” and “folder path missing”

Syncthing is ran as use deck via systemctl --user all files in ~/.var are owned by deck:deck and have perms rwxr-xr-x

trying out more paths:

  • ~/New Folder - creates .stfolder and syncs fine
  • ~/.var - creates .stfolder but protection error about some files in ~/.var/app/me.kozec.syncthinggtk/*
  • ~/.var/app - does not create .stfolder and protection files about some files in ~/.var/app/me.kozec.syncthinggtk/*
  • ~/.var/app/New Folder - does not create .stfolder

I don’t want to have to move the save files and save state locations of the emulators as I don’t want to have to recreate the symbolic links that emu deck created in the Emulation/saves folders.

I found these topics:

The second topic mentions how they had to turn on “Ignore Permissions” in Syncthing due to the Windows peer changing the file permissions somehow. This does not look relevant to you but its worth thinking about.

I tried installing Steam Deck following these instructions so that I could try reproducing your problem (tinkering with SteamOS looks interesting), but I keep running into errors during the installation process.

I might try and see if flatseal works, I’ll post an update on any results.

Progress, there is now a .stfolder folder

And syncing works, good

The solution is;

  1. Open Discover and Install Flatseal by searching for flatseal in the search box
  2. Once installed, launch flatseal
  3. On the left scroll down until you find “Syncthing GTK” and click on that.
  4. On the right scroll down to the “Filesystem” section
  5. In Other Files click the button on the right with a picture of a folder with a + plus sign
  6. Type ~/.var/app:rw
  7. Close flatseal and restart the Steam Deck (or find a way to restart sync thing, I tried via the web interface and systemctl, and nothing changed but restarting the Steam Deck worked the best).

Then it should work to sync folders inside of ~/.var/app.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.