Slow Download Speeds <400KiB/s


I use syncthing to sync files between my seedbox and computer but recently my speeds have just tanked from being 13MiB/s to less than 400KiB/s.


I have restarted synthing multiple times on both the seedbox and my computer to no avail. I can conclude that the problem lies with syncthing on my computer because I tried syncthing from my phone to my seedbox and got my normal 13MiB/s speeds. I have tried looking through the forum and FAQ but haven’t found any solutions so any advice would be appreciated.

Search the forum for old threads for clues of what you can check. These sort of issues have been discussed many times.

I have checked but can’t find any conclusive solutions just a bunch of abandoned forum threads

Which is the computer OS?

Windows 10

What have you checked so far?

I have uninstalled and reinstalled synthing on both devices. Removed and added back the shared folder and remote device on both my computer and seedbox. Besides that nothing else because I’m not that comfortable or knowledgeable to do more in depth troubleshooting.

I think most of the threads that talk about this subject (and the FAQ) suggests to check the connection type between the devices. Have you done that?

Yeah my connection type is my computers ip and then the port. It’s not a relay connection (as stated in the FAQ).

Sure, it’s a direct connection, but there are direct connections of different types.

Are you syncing a lot of small files or a few bigger files? Syncthing has a non-trivial overhead per file, so if you are syncing 1000s of 4kb thumbnails, slow speed might be expected.

No I’m sycing fewer big files ranging from 300MiB to 10GiB

In which case I suggest you check cpu/ram usage, disk busyness (iowait etc). Also, make sure they are connected using TCP.

Maybe add an incoming firewall rule on Windows for syncthing.exe?!

From administrative command line:

netsh advfirewall firewall add rule name=“Syncthing” program=“FULL_PATH_TO_SYNCTHING_EXE” description=“Syncthing” enable=“yes” profile=“any” localip=“any” remoteip=“any” action=“allow” edge=“yes” dir=“in”

My cpu and ram aren’t being stress enough to cause slow speeds and I am using TCP

I tried the command but nothing changed :frowning:

Any fancy firewall/AV software installed?

Is the storage stressed? Did you check both sides?

nope just basic windows defender

nope there is plenty of storage on both sides

Just to clarify, my question is not if you have space, but whether the disks are busy and have a lot of io operations queued up, this is usually because they are slow spinning disks.

On windows this can be seen in task manager. On linux using iostat.

1 Like