Setting up new folders for sync -- permissions problems

I’ve been running into this issue when I create a new folder for syncing. Here’s what I did:

  1. Added a new folder on Node 1. (It already had files in it.)
  2. Shared it with Node 2 when adding.
  3. Created a blank folder in Node 2.
  4. Accepted invitation on Node 2 from Node 1.

But then I received these error messages:

I tried the following to remedy the issue, but to no avail:

  • Set permissions of Node 2 folder to 777, then restarted
  • Set the owner of Node 2 folder as “sc-syncthing”, then restarted
  • Added user sc-syncthing to parent (Backups) folder with read/write permissions, then restarted
  • Added .stignore and .stfolder manually with permissions as 777, then restarted

None of the above worked. Currently the permissions are set to: drwxrwxrwx+ 1 USER sc-syncthing

On Node 2 it’s a Synology DS916+ running DSM 6.0.2-8451 Update 9.

Help? Thanks!

OK I think I answered my own question! But posting the solution here in case anyone else has this issue…

When adding a new folder to Syncthing, make sure the sc-syncthing group has permission to write to that shared folder on the Synology NAS.

Go to Control Panel > Group and select sc-syncthing. Then click Edit. Go to the Permissions tab in the next window and make sure the Read/Write checkbox is checked for any top-level shared folder that are being used for Syncthing.

That did it for me.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.