Out of sync 13 itmes -> but not shown in the list

Version 1.8.0


The list is empty tested in firefox and chrome Restart did not solve it

1 Like

That’s not a web UI/browser issue: That’s an “accounting error”. The numbers are adjusted on the fly when registering changes, while the list is populated from the db every time. Unfortunately there’s no real angle to debug this after it happened. If there’s anything special about that folder or you remember when you first noticed it and what you did/happened just before, please let us know. You can recalculate the numbers by running Syncthing once with STRECHECKDBEVERY=1s.


So, just to clarify: the list is the source of truth in this situation?

1 Like


1 Like

So, in a slight ironic twist, I’m now experiencing the same issue as OP.

What is the best way to run Syncthing with STRECHECKDBEVERY=1s just one time?

Something like syncthing --STRECHECKDBEVERY=1s, or (?)

Edit; For anyone searching, my problem itself is the same as OP, in that there appear to be 4 files that haven’t synced between two machines, and there has been no data transfer for several hours. All files appear to exist on both machines. This was a clean share set up today between a stock macOS machine and a stock Manjaro installation. I have rebooted both machines multiple times, as well as checked permissions.

I’ve already tried syncthing -reset-deltas as well with no fix.

STRECHECKDBEVERY=1s is an environment variable, not a command line switch. You can google how to set an environment variable in your shell on your operating system.

Try also 1.9.0-rc.5


Thanks for the pointer! Now that I knew what term to search for (environment/shell variable), I was able to learn in just a few seconds. Happy to be on Linux, and learning as I go. :slight_smile:

So I gave it a try. First, I stopped Syncthing via the webUI shutdown command (and verified by refreshing the page to see the service was indeed down… or at least the webserver)

To start Syncthing again, here’s what I ran:

After several minutes, I then reopened the webUI to check the folder status. Same story:


Four files on this destination showing as out-of-sync, however the source machine isn’t sending anything.

Clicking on the OoS counter doesn’t give any details:

Now, on to the source (had all files) machine

As you can see, the share folder does not show the same four-file discrepancy at first. (the ignore pattern on the source is just for .DS_Store macOS garbage files)

This screenshot shows send-only mode, as I was trying to force a sync with a temporary send-only/receive-only setup (to no avail). This has since been reverted, with no fix found.

Next, here is the details as the source sees the destination:

Same story. Out of sync. No transfer.

When clicking OoS for details, here is what the source shows:

What’s really strange here is that I have personally verified, and even opened, all four files on both machines! They are present. And yet, the file counter and list and sync status is all off.

Steps I’ve taken:

  • Clean install of Syncthing on macOS and Manjaro
  • Rebooted all machines
  • syncthing -reset-deltas (after manually stopping service)
  • STRECHECKDBEVERY=1s environmental variable in shell (after manually stopping service) and then restarting from that same shell after echoing to verify setting
  • Forcing send-only to origin, receive-only to source, rebooting several times

So… what now? Anything else I can try to help here?


We fixed a related bug.

By the way, your environment setting is not correct. You need export STRECHECKDBEVERY=1s if you’re going to do it like that, with the export meaning to sub-processes. Otherwise you’re just setting it in the shell but not applying it to Syncthing.

1 Like


Secondly it didn’t work because environment variables are local to the process you set it in, unless you export them. So either



1 Like

Good to know!

Silly question: doesn’t the export make this permanent, or only until the next session/reboot?

(I promise I DDG’d it, this is all just a bit confusing as I learn)

EDIT: as for 1.9.0-rc.5, I will attempt this. Looks like I’ll have to stray away from Package Manager to make it happen…

EDIT 2: I just noticed your formatting here, for STRECHECKDBEVERY=1s syncthing, and I will try that now. Thanks.

No, just for the current shell session.

1 Like

Good news; with my corrected syntax of STRECHECKDBEVERY=1s syncthing, it appears to have done the trick.

Calmh and imsodin, thanks for your patience while I learned shell.

Strange news, now all of the folders are greened-up with no pending syncs, and yet I now have more files locally than globally.


Uh… fantastic, what did I break now?! :beginner:

(Both computers show Up to Date, and both agree on the Global State size of 13,496)

Just a followup with a (final? knock on wood) fix:

Some DDGing and Reddit crawling later, it seems that the 1s interval may have been too strong for a ~60GB shared volume (among 250 GB of others).

Ran again with a 4-minute interval, shut down 5 minutes later (Ctrl-C), and restarted the daemon for a full fix:


Y’all are the best :heart:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.