not syncing only creating tmp files

last few days my systems are not getting sync - only files with ~syncthing~filename,ext.tmp are getting created - and in case we want to use = need to rename, say filename-check.ext and decide whether local copy is final and new copy and than delete another one-- but that kills the purpose and some time we can unknowingly start using old file already available in system


Typically you should see errors in the GUI and/or logs explaining why sync doesn’t complete.

yes, thats what it says, but i am not expert or will say i am novice to udnerstand it. one of the error is item “pdf files\flourish inv.pdf”): syncing: no connected device has the required version of this file

and another error is \qc_newpc_doc\COA -LAKE COLOUR\LAKE SUNSET YELLOW\SS12\OLD COA\SS12(KE151)LETTER HEAD.doc: Access is denied.

the two errors combines makes nearly all error

so what i am left is original file and one temp file and before opening any file - i need to decide what could be final version


I am a total beginner with informatics and I have been using syncthing for a few month, it has always worked pretty well but since last week it won’t sync anymore but creates the same type of file : ~syncthing~filename.ext.tmp I tried to create a new folder to see if the problem was the same and it is. The only information I could find on the web interface is by clicking on the line “failed items” and it says “acces denied”.

I couldn’t find the logs as you suggested, I don’t know where to find it even with the help documentation.

I really don’t know how to solve this problem and barely understand it. Also I don’t know how to use command lines…

try few things i could understand- though not sure if that can actually create more problem- like

  1. remove sync and added once more
  2. removed sync, deleted folder from one of the system , and than created sync with one as sender only and another as received only systems - and still it is creating temp files only and than giving error message like rename - access denied [UHGUS] 16:25:55 INFO: Puller (folder “QC documents” (ywgxd-ues5h), item “LABLE\OLD\LABLE 2014-2015\LAKE COLOUR\LA PHARMA\CR22 131214.docx”): syncing: rename \?\G:\qc_newpc_doc\LABLE\OLD\LABLE 2014-2015\LAKE COLOUR\LA PHARMA~syncthing~CR22 131214.docx.tmp \?\G:\qc_newpc_doc\LABLE\OLD\LABLE 2014-2015\LAKE COLOUR\LA PHARMA\CR22 131214.docx: Access is denied.

so not sure how to go about it

hellow! anyone has suggestion or similar issue? I tried to remove sync, and than doing it again, remove sync and than re- sync on another location in other system

only thing that may have been left out to try is may be remove the whole syncthing software, remove leftover setting and than reinstall and do sync again??

or can i try to install and older version and check if that works?

any suggestions???

Reinstalling will likely not change anything.

Please explain how you installed Syncthing (to find out under what user it runs). Then for the files were you get permission denied errors, check their permissions. Post a screenshot if in doubt.

error message - 2022-01-05 17:09:03 Puller (folder “Server Docs” (hia3q-ifo2k), item “my files\standardcon outstanding payments.xlsx”): syncing: removing item to be replaced: remove \?\D:\Google Drive\my files\standardcon outstanding payments.xlsx: Access is denied. screen shot of temp file created as well as proeprty of file it says not able to delete!! actually this happens to all files we edit on any system - it simply created temp file and do not delete /replace old file - nor it gives sync conflict erro

The conflict might indicate this file is opened/edited often - I assume excel is protecting the file while open, which might cause this.

The file isn’t read-only, that’s one bit. However the main information about permissions is in the security tab. And it’s still also necessary to know how you installed/run syncthing to figure out the user.

By the way thanks for the response! i was about to abort syncthing. Open is frequnetly? The issue as i said has started coming with all files we change on another system, it do not get propogated , but created as temp files on my main system!!!

By the way advance proeprty screen shot also for this file Screenshot 2022-01-05 180702

security tab details - i have tried to allow as many things as possible to security setting also to bypass the issue!

I am just trying to spot things that might cause it - I don’t know your setup in depth so naturally most of my guesses won’t apply. I still need to guess, to maybe find that one that does apply :wink:

Those permissions do look good superficially (I don’t have much knowledge of windows permissions). So further into speculation mode:

  1. Are the permissions on the parent directory good as well? Under linux parent directory permission also control if a file in it can be deleted. 2. Is this some special filesystem which mounts your google drive, and/or is a tool running which syncs this directory with google drive? That might interfere too.

This may be wrong, but I’d assume Google Drive may be trying to sync the Syncthing’s tmp files, and lock them in the process, so that Syncthing itself cannot rename them later.

I’d suggest either testing Syncthing outside of the Google Drive folder first, or at least close the Google Drive application before testing Syncthing.


It’s been some time since i last used gdrive but doesn’t it offer excludes? You could simply exclude syncthings tmp files.

  1. same permissions
  2. google app syncing file and not a special drive but google drive has been stopped by me since the issue has occured actually i sync different folders from differnt system – and google drive is only for one of them, the temporary file issue is happening in all folders

have stopped google sycn long back – now will try uninstalling it and see if issue gets sorted out, thoigh i feel that is not the issue - as i was using google sync since long and there was no issue

most probably it do not allow exclude

have un-installed google drive sync , and the issue remains!!!

What user account are you running syncthing as?

The file is owned by “Guest”, which might not be the account that is running syncthing from what I understand.