Many Out of Sync items after inital sync

(Andreas Balogh) #1

I have setup syncthing to backup files from my Windows 8.1 laptop in C:\Users (source) to a freenas 9.2 based syncthing (target). After setting up the C:\Users folder the initial syncs begins. The source folder is configured as a “Folder Master”. After the initial sync the target shows “Out of Sync” for all files. I checked the directories with freefilesync and found that in the target all files are replicated with a “.syncthing.” prefix. Enclosed find screenshots of the

  1. target syncthing

  2. target directory listing

root@syncthing_1:/mnt/backup/laptop1 # ll                                       
total 216                                                                       
-rwxrwxr-x+  1 syncthing  syncthing    0 Apr 19 19:09 .stfolder*                
-rwxrwxr-x+  1 syncthing  syncthing  174 Apr 19 19:38 .syncthing.desktop.ini.tmp*                                                                               
drwxrwxr-x+ 20 syncthing  syncthing   26 Apr 19 19:32 Andreas/                  
drwxrwxr-x+ 12 syncthing  syncthing   18 Apr 19 19:28 Default/                  
drwxrwxr-x+ 13 syncthing  syncthing   14 Apr 19 19:16 Public/                   
drwxrwxr-x+ 16 syncthing  syncthing   23 Apr 19 19:39 balok_000/                
drwxrwxr-x+ 16 syncthing  syncthing   23 Apr 19 19:39 bkpop/                    
drwxrwxr-x+ 16 syncthing  syncthing   23 Apr 19 19:38 werkstatt/                
root@syncthing_1:/mnt/backup/laptop1 #                                          

What should I do to let syncthing complete the sync operation?

Regards, Andreas

0 Likes

FreeNAS Syncthing plugin permissions strangeness
(Audrius Butkevicius) #2

Check the logs for errors potentially, especially if all items are actually there, but still with the temp file prefix/suffix.

0 Likes

(Andreas Balogh) #3

Permission issues. Will check the other thread about freenas permission issues.

[WFPDS] 21:54:30 INFO: Puller: final: chmod /mnt/backup/laptop1/Andreas/AppData/Local/Microsoft/CLR_v4.0_32/UsageLogs/.syncthing.Con
nectifyShutdown.exe.log.tmp: operation not permitted

Hm, strange. I’ve configured a new dataset as described in Permission Denied on any path I choose (FreeNAS) but I still get the chmod errors. Will try a) storage local to the jail (not mounted) and b) and UNIX dataset later. Btw: adding logs to syncthing in a freenas jail works by adding /etc/rc.conf.local

syncthing_args="-logfile=/var/db/syncthing/syncthing.log"

0 Likes

(Andreas Balogh) #4

Problem solved by using UNIX permissions on the freenas dataset.

Actually, this issue is duplicate of Large repo synced but only tmp files received. The root cause has been discussed in the freenas forum https://forums.freenas.org/index.php?threads/cant-chmod-files-operation-not-permitted.22229/. For further reading search https://www.google.com/search?q=freenas+syncthing+permission+chmod.

TL;DR: freenas does not support chmod with Windows permissions. Windows ACLs are stored in extended attributes so chmod is disabled as a safety to assure consistency in permissions. Syncthing fails the download if a final chmod fails.

For syncthing trying setfacl when chmod fails would elegantly get rid of this issue. Should I open an enhancement request for this?

0 Likes

(Jakob Borg) #5

We don’t support syncing ACLs, but there is an issue for it somewhere. Without that I don’t it makes sense to do setfacl calls. Another workaround would be to disable syncing permissions, by the way.

0 Likes

(system) closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes