Internet provider Yota blocks the name

Good afternoon. My internet provider Yota blocks access to, pointing to does not help. Syncthing is unable to load the list of relay servers and fails to connect devices, which results in an error: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond . If you enable VPN globally on a machine running WIN10, then everything works. Is it possible to somehow defeat the YOTA provider without using an additional VPN and downloading the list of relay servers from a different address? If so, how can I set up Syncthing? Many thanks.

Synchronization also stopped working, the first host died around May 18, then the rest stopped working. Most likely the problem is related to the blocking of DigitalOcean addresses. Devices work through Russian providers Megafon and Rostelecom, operating systems Android, Windows 8.10, OrangePI (Ubuntu). The latest version of Syncthing is installed. Is it possible to solve this problem without using a VPN? Thank you.

Without a VPN, you may run your own relay server and hardcode its address in Syncthing instead of the default ones. If you want to go this route, please check for details and instructions. Of course, some kind of a static IP address is required.

This path is too difficult. I have 4 computers for which I use Syncthing. Isn’t there an easier solution?

I don’t think so. Syncthing should still work fine on your local network. Outside of it though, it’s either up to relays or, if your devices use static IP addresses, you can hard-code them instead and disable relaying whatsoever.

tell me please, static ip is needed only on the device on which the relay server will be installed? Is it possible to solve this problem using DDNS (without using a static IP), for example ?

This solution is good when you have all computers on the same network and you can allocate a static address. But not in my case. I have 2 laptops with mobile internet providers that can’t give out a static address. 2 computers that are connected through different Internet providers, which can give a static address, but I will not do this economically.

Tell me step by step how you can connect to one (for example from the map of relay servers from here I can not. syncthing doesn’t like the http protocol.

I’d say yes to the first question. As for the second one, I’ve got no experience with any of those services, so someone else will probably have to chime in and answer it. Otherwise, you will need to do the testing yourself.

It’s explained in the Docs linked a few posts above, but the address should look like relay://<host name|IP>[:port]/?id=<relay device ID> (e.g. relay://

However, hard-coding any of the relays listed there isn’t really a wise option, as the servers may come and go any time, so there’s zero guarantee that the one you’ve hard-coded will be available tomorrow.

Does not help. Error: Global discovery: unsupported scheme relay

I unchecked the global discovery checkbox. The error went away, but the connection failed. Help in which configuration lines should this instruction be?

The information has changed. The relay I have chosen does not have information about the computer I need. Is this possible?

Relays are configured in the Listen Addresses, not the discovery server configuration.

Thank you. I have already placed the necessary line in the line you specified.

How to ask the desired machine to communicate with the selected relay?

I think you need to do something like this.

The screenshot’s using the relay example taken from the Docs. Obviously, you need to replace it with your own. I’d keep default there too.

Also, the relay address needs to be added like that on all devices.

1 Like

unfortunately this solution doesn’t work. computers cannot connect to each other for several days.

Can you show screenshots of your configuration on both devices? I’ve just tested this myself using the very first relay listed on, and my devices have almost immediately connected right through it.

Full string Sync Protocol Listen Addresses: default, relay://, relay://, relay:// the difference is that you have a static one, and I have a dynamic one

Something isn’t right, because if you look at the log in SyncTrayzor, it keeps complaining about the relay ID not matching.

Also, you may want to confirm that you can actually connect to the relay by pinging the IP, e.g. ping, etc. If you’re not going to set up your own sever, then I’d at least recommend to try finding a relay server that’s also located in Russia, so that there’s less chance that it could also become inaccessible in the future.