In general except hidden folders, but some ...

#1

Hello, I work on Linux an wanted to use the following ignore list:

!.local/share/rhythmbox/

.*

In general all hidden files and folders of my whole home folder shall be ignored, but not the sub folder .local/share/rhythmbox.

But I get the error message: error while traversing /home/dirk/.gvfs: permission denied.

If I remove the line !.local/share/rhythmbox/ the error is gone, but then I miss this folder.

0 Likes

(Simon) #2

The problem is, to find all included (!) paths all paths, including ignored ones must be traversed.

The actual error you get comes from a limitation in the library used for the watching for changes feature: If it encounters any error while setting up watches, it fails, i.e. there is no way to just dismiss errors on ignored paths.

Workarounds: Change permissions such that syncthings user can traverse all folders in your home or disable watching for changes. The ignore patterns are fine.

1 Like

#3

Thanks for your help, it was very helpful.

0 Likes

#4

Ok I understand, that watching does not work in such case, but there is still one question.

  1. I turned OFF watching and there I get the error messages: .gvfs permission denied. It seems to be that filter is NOT correct.

Thanks in advance.

0 Likes

(Simon) #5

Where do you get that error? And it looks like that’s not the full error message.

0 Likes

#6

The error was shown above. But in the mean time I changed the access rights. I hope I won’t get trouble. The complete error message started with any support information. I don’t know anymore the correct content.

Thanks for your help, I think it’s ok now.

0 Likes

(system) closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes