Folders up to date but remote devices never seen?


(Mega) #1

Hi guys! First post here and first time Syncthing user, so sorry for sounding and acting like a newb. I imagine my question is a very simple one and I would say it should be very frequent… I did check all the FAQs and searched through the forums, but the only related questions I found did not answer specifically what I was looking for and were related to (much) older versions of Syncthing.

So basically I want to set up a connection between my laptop at work and my laptop at home.

• Both Windows 10 64 bit • Both using v0.14.46, Windows (64 bit) • They are not on the same network

These two machines never connected to each other (bottom right at the GUI) yet folders show as up to date (top left at the GUI). No folders show up on the target machine so I’m pretty confident they never synced.

Address is shown as dynamic and while I may have to configure port forwarding, shouldn’t relay work as a slower but successful method out of the box? (BTW, I won’t be able to configure port forwarding on the work laptop).

Thanks in advance!


(Audrius Butkevicius) #2

It should. Check if you got device ID’s right, and check what addresses syncthing discovered for the other device.


(Mega) #3

It miraculously started working after your post (well, not exactly miraculously, because I also changed from LAN to Wi-Fi). Therefore, device IDs are right.

How can I get this to work through LAN? Once again, I can’t enable port forwarding at work.

Thanks!


(Audrius Butkevicius) #4

Well it’s not clear what’s wrong as you haven’t provided any additional information other than that it does not connect. Perhaps your LAN has firewalls and proxies that need to be setup, but a screenshot of the UI should explain whats up.


(Simon) #5

Port forwarding on one side is enough, i.e. if you can forward at home, you can connect directly. For everything else, what Audrius said.


(Mega) #6

Even if these folders are “Send Only” from work?

My previous attempt of attaching a screenshot failed… here’s another one: https://ibb.co/fsT54x


(Simon) #7

Establishing connection has nothing to do with folder configuration. Your screenshot shows, that the devices were never connected (last seen: never). If you didn’t mess with the discovery settings, the most likely cause is misconfigured device IDs. If you don’t find the error yourself, post screenshots of the device edit and settings->connections dialogs.


(Mega) #8

My bad for maybe not explaining properly… The first screenshot I sent was before I’ve managed to connect the first time (before I tried Wi-Fi).

This second screenshot https://ibb.co/jO2h1c was after I’ve managed to connect (through Wi-Fi) without changing anything else. This shows that device IDs are definitely correct. Remote Device is Disconnected since connecting to LAN once again.

I didn’t mess with any discovery settings whatsoever.


(Simon) #9

Did you restart Syncthing when switching between LAN and wifi? I don’t know whether that’s necessary, but wouldn’t be surprised. Otherwise the fact that it works on wifi is a pretty good indicator that the problem is with a firewall/proxy/routing in your LAN. You can also check whether your log contains a line with Joined relay relay://... to see whether that worked. But for actual use (not debugging), do setup port forwarding on your home computer to get direct connections.


(Audrius Butkevicius) #10

It seems that your network is blocking discovery, as no remote addresses are shown and discovery is 3/5 or whatever, hence it can’t discover the other device. Most likely a http proxy issue.


(Mega) #12

Any way to circumvent this without changing work http proxy?


(Audrius Butkevicius) #13

It’s very unlikely syncthing will work in an environment like this as if its blocking http, it will block unusual network connections.

You can try setting HTTP_PROXY and SOCKS_PROXY (if you use socks) environment variables with the proxy addresses.


(Audrius Butkevicius) #14

Can you enable connection log and post the logs as it tries to connect?