Folder Path Issue

Hello, I’m attempting to setup syncthing between my two NAS devices and am having issues with the path setup. On NAS 1 (QNAP), the folder exists in /homes/folder/ and in NAS 2 (Synology) I want the path to be in /volume1/folder/ because I’ve created a dedicated shared folder on this NAS for it. No matter what I seem to do, the synced folder ends up going to NAS 2 as the identical path that exists on NAS 1. So a /homes/folder/ path gets created and syncing happens between there. I’m totally new to all of this, but am I correct in my understanding that I should be able to set the path where the shared folder should exist on a given NAS? Thanks for any advice you could give me here.

Not an expert, but it sounds similar to the issue described at Basically, your OS may be restricting each app’s access to a specific folder, so that it’s impossible to create folders outside of it.

How have you installed Syncthing in the first place? If it’s a 3rd party package offered by the NAS vendor, then you may want to try running the official binary from instead. This may not work if the OS is extremely restricted though.

Sun thing

Hey so im running QTS 4.5.4 on NAS1 and installed sycthing from › qpkgSyncThing - Qnapclub Store

On NAS2 I’m running DSM 7 and installed sycthing from SynoCommunity

Are you implying that something could be deficient in these versions of syncthing?

Syncthing itself could be unmodified, but the package format may follow the OS restrictions that force it to access the filesystem under those specific paths only. Of course, this is just speculation at this point based on your explanation and the other issues that have come up on the forum recently.

That’s why testing out how the official binary behaves in this environment may be beneficial and hopefully verify (or not) this suspicion.

Also, please post screenshots showing the Syncthing Web GUI on both sides, including the problematic folder paths, so that we can check visually whether there’s nothing obvious going wrong in them.

As maintainer of the SynoCommunity package, I can at least say that there should be no artificial restrictions to a folder’s path in that Syncthing package. You can point it to wherever you like, just need to make sure the permissions are set correctly. There is some info on the SC Wiki about this, sorry just don’t have a link at hand right now.

Screenshots would be helpful, yes. And maybe describe the process what you did to set up the folders on each side. Note that the default folder path in the Settings dialog is not relevant for already shared folders. You need to look at the expanded details for the respective folder in the GUI to see its path.

In DSM 7 there should be a local system user (it´s not a normal user or a usergroup!) “sc-syncthing” and this user gets read/write permissions via the control panel in all those folders that should be synchronized. If you then want to create a folder, you can then also select this.

Thanks to all of you for weighing in on this. I can’t seem for the life of me to be able to recreate the setup I once got - before I could see files syncing, but now I don’t even see that; though the scans and changes seems to show on the web GUI, I can’t see them in either NAS file station.

Here are screenshots of the setting on the QNAP NAS:

Here are ones of the Synology NAS:

The shared folder on the Synology has “sc-syncthing” permissions for read/write enabled (and subfolders).

I know I must be missing something obvious…

Could it be related to this? Could anyone expound on this for me?

I meant clicking on the folder name in the GUI’s left column. It will expand to show more details about that folder. But you already showed the paths in your screenshots above, so that looks correct.

What exactly are you seeing? If Syncthing is configured to sync /volume1/DKR_Creative path on the Synology, then it definitely won’t try to access any other path for the folder. How did you come to the conclusion that Syncthing is using /homes/DKR_Creative instead on that same system?

Hi Andre, before I was placing files into the folders and they were syncing. On the QNAP NAS the folder was in /homes/DKR_Creative

My intended location for where to send it on the Synology was /volume1/DKR_Creative but no files were actually showing up there when I tested the sync. They were showing up in a folder at /homes/DKR_Creative on the Synology (the same path location as the one on the QNAP)

Here is an outline of my process:

  • [ ] Create New Shared Folder on QNAP: /homes/DKR_Creative

  • [ ] Permissions set to RW access for all administrators

  • [ ] Create Shared Folder on Synology /volume1/DKR_Creative

  • [ ] Allow sc-syncthing read write permissions

  • [ ] Connect Remote Devices on Synching web GUI - neither Introducer or Auto Accept are checked on either NAS

  • [ ] Create Folder on QNAP NAS labeled: DKR_Creative

    • [ ] path - /homes/DKR_Creative
    • [ ] Check Sharing to share with Synology device
    • [ ] Advanced > check ignore permissions
  • [ ] Accept Folder on Synology NAS

    • [ ] Folder name: DKR_Creative
    • [ ] ID (same on both)
    • [ ] path - /volume1/DKR_Creative
  • [ ] Outcome = says “Up to Date”

  • [ ] On Synology, I can see .stfolder

  • [ ] On QNAP I don’t see the folder

I still don’t see files syncing between them. :man_facepalming:

Maybe is better to have screenshots of the 2 GUI´s to see the status, because if “Up to Date” appears and there are no files, it indicates a connection problem between the devices. In which condition are the remote devices, are there disconnected or connected?

If the QNAP also shows “Up to Date” and the .stfolder is not visible, maybe this file could fall under the hidden files and in this way are not visible.

I’m still really confused by this contradiction. Did you change something, did you set it up again from scratch?

The .stfolder not showing on the QNAP side could be related to not showing hidden files, correct. But I thought the problem was on the Synology side, where the files ended up in the wrong location? Are you maybe just mixing up the Web GUIs of both NAS instances?

And when you write “Create shared folder”, are you talking about the NAS user interface or about pressing “Add Folder” in the Syncthing GUI?

Thanks for sticking with me on this…I’ve spent so many hours trying to get this working!

Yes. I setup all from scratch. When I first posted the issue was that files ended up in the wrong location on the Synology side. Instead of going to where I set the path /volume1/DKR_Creative they went to /homes/DKR_Creative

NOW the issue is worse. I am not even seeing any files sync between them - but the web GUI says they are.

Sorry to be unclear. The first two instances of my outline are on the NAS devices:

When I said “Create Folder” here, I should have said “Add Folder” on web GUI:

Yes, things are “up to date” but I also have “Show hidden files” checked within the QNAP file station and nothing shows which is bizarre.

As of now, the web GUI says things are syncing and up to date, but nothing is showing to sync in my actual file system…I did a video of how I set things up here: Syncthing - YouTube

Maybe check via console the situation inside of that folder.

Normally, if no .stfolder is available, in the GUI you get a Stop message and the Sync doesnt work. Whats happen, if you simply copy a .stfolder in the folder of the QNAP, maybe then the Sync works.

Hey Andy, I don’t really know how to use Console…I can look into it and see if it’s something I can figure out to check this.

A couple times I’ve tried creating a folder .stfolder within the QNAP filestation in the correct path, with no noticeable results.

Was that folder visible and have also the right permissions?


What is the reason .stfolder is away now? Manually or virus detected or any scripts seaching such files for deleting, etc.?

That is very dangerous advice. If Syncthing detects that folder marker in an otherwise empty folder that is shared to other devices, it might assume that all files have just been deleted and goes on to delete them on the other nodes. Don’t do that.

I don’t have time right now to look further into the actual problem, maybe later or tomorrow.

1 Like

That may be and I knew that now not quite so conclusively.

When I read the whole post, I have to assume that the folder in question was created regularly via the GUI and thus also the .stfolder. If this now gets lost and I copy again a .stfolder into the directory, the sync works as before. The folder is usually empty and it does not matter where it comes from. I had also already accidentally deleted some and always fixed it in this form.

However, I do not want to call now to the imprudence, I am finally no specialist or programmer.