Failed to create config: duplicate or new?

I just tried to add a device to syncthing-android. I got the little black message thing saying:

Failed to create  a Syncthing config. Please check the logs.

I use version 0.9.3 on Moto G titan rooted stock Android 6. To collect a log I ran logcat in root adb shell (running adb shell logcat didn’t work as logcat never terminates?) and copied it over: log.txt (667.8 KB). I have almost no android knowledge, so no idea what this might be about. I found

which are either the same thing or related (or not at all). Can an android dev tell me how to proceed to produce most useful information for you. Or if this is irrelevant, please say so too, then I can start trying to solve this the messy way - thanks.

I cant see any problems in the log, Syncthing is starting normally. Maybe try to restart your device if this persists, and/or reinstall the app.

Reboot didn’t fix it, reinstall did but on doing the exact same steps the error appeared again:

  1. Install
  2. Change device name and check running as superuser.
  3. Restart syncthing
  4. Add a device.

After step 4 the syncthing app closes and the described config error message appears every time I try to start it. Is there any way I can provide more helpful information?

Ah, root is kind of bugged, there are various issues on the tracker. Unfortunately, I don’t have time to fix any root related issues myself.

That’s a pity, I was so happy that I didn’t have to mess around with linking or bind mounting or whatever to give syncthing access to the sd card. Well it seems I do. Thanks anyway for your help.


Just in case anyone has the same problem: My solution was to use XPosed with which (as a side effect) grants all apps access to the extern sd card. So syncthing folders on external sd card runs happily (well, it uses up tons of resources even when idle, but that’s ok as I don’t run it permanently).

1 Like