Disk cloning problems

(Andrew) #1

I found this thread about my issue:

Changing the ID after a clone

I followed these instructions: “Erase the files cert.pem and key.pem in the config directory. Also, the index-v0.11.0.db directory.” And did not do this bit because I wanted to keep the folder config. “In fact, everything in there unless you want to keep the folder configuration. :slight_smile:

Tried connecting but saw a message go by on the console about connecting to self - not ok. So killed it to start again.

This time deleted everything in config. Tried again. Got requests to connect from one of the others on the network. But this seems to be trying to connect to two IDs of this computer, and no connections are working with this computer.

(Audrius Butkevicius) #2

Each syncthing instance only has a single ID, so I am not sure what your statement or question is, as there is no logs to try and explain the problem.

(Andrew) #3

Thanks for the reply.

I know that much. That is how I know something is going on I have no idea how to explain! Where would I find the logs to send in? I googled for syncthing logs and what I am finding is not much help:

“If I understand correctly, Syncthing writes out log messages on stdout. So, the nature of logging and the location of log file, if any, depends on the how Syncthing was started. Would it be possible to document simple ways of logging (something similar to http://docs.syncthing.net/users/autostart.html would be great)?”

(Audrius Butkevicius) #4

The logs are accessible from the UI, as well as printed to stdout, but you have to figure out how syncthing is launched and where whoever is launching it is putting the logs in order to get the full log.

(Andrew) #5

Please could you give a bit more info. What does ‘whoever is launching’ mean?

(Audrius Butkevicius) #6

Sorry, but this is beyond syncthing, if you have no idea how it’s being launched, I cannot help you.

(Bt90) #7

Which Operating System? How did you install Syncthing?

(Andrew) #8

Using LMDE2 betsy. Syncthing was on the cloned drive. It was installed on the command line on the original drive some time ago.

(Audrius Butkevicius) #9

LMDE2 betsy this means nothing to me personally, and still doesn’t answer the question how syncthing gets started.

(Andrew) #10

Sorry. Did not understand. It is started on startup. It is in Startup Applications

(Bt90) #11

Is syncthing running as a systemd service?

(system) closed #12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.