Device X folder Y has a new index ID

I run syncthing across three servers as a docker within unRAID (three-way sync). When a new version of syncthing comes along I just pull a new docker image (the docker maintainer keeps it up to date). I’ve been doing this for over two years now and it’s been great.

However, yesterday I updated to version “1.27.6” and noticed today that one of the three servers has a whole bunch of “new index ID” messages. The other two servers are ok.

I came across this article and I quote calmh below. Unfortunately I haven’t done any of the things mentioned. Is it possible that a DB migration occurred without me knowing? If so then why only on one server? The article below mentions that the message is just an info message but I’m a little worried as to why this happened and why it happened to only one of the servers.

New index IDs happen when devices connect the first time, or on database migrations which happen now and then, or when forced by -reset-deltas. It’s not an issue, and by definition happens only once so resolves itself automatically.

1 Like

I have to admit that it’s tough following what’s going on here. Maybe it’s obvious to the developers here. I see that this was a recent change but the comment only says “Resend our indexes since we fixed that index-sending issue”. What index-sending issue?

So I tried to search for info about this and I found a few things usually talking about an initial sync but nothing really explains what happened in my case.

Looking at the code you get a sense that there’s a version mismatch so maybe in my case it was a matter of timing where one syncthing device was updated while an older device was still up. That’s just a guess.

Anyway, I gather that the indexes were dropped and are now being recreated and this is basically a non-issue.

I do appreciate the help and quick response. Love syncthing so keep up the great work gang.

What you’re seeing is the solution to Some deletions and modifications getting stuck in sync since v1.27.5

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.