Device stays out of sync until restart

That description in the PR sounds exactly like what is happening.

“This problem likely existed for a long time” I can confirm that v1.10.0 also seems to drop indexes on one side, however it looks like they are resent so it does not matter that much.

Running the build from the PR now on the test setup, before the upgrade I had the issue once again there, so it also seems to happen quite often. Will see if it happens again, if not I will try it on the real setup in a few days.


Maybe such processes are normally under circumstances, I don’t know how it works with the indexes. I couldn’t judge that. However, there must be a more substantial difference between v1.10.0 and the following. Quiet seems returned since I downgraded all devices.

Yes Andy, there have been significant changes related to this in v1.11.1 and v1.12.0 - as documented in the changelog. Thanks to all the debugging in this thread we have actually found problems and are fixing them right now. Downgrading may be a necessary and effective measure, but it’s not a permanent solution nor does it help fix problems.

1 Like

Tested latest fixes on the test setup for a few days without issues so I also tried it today on the real instances: also no out of sync or other issues even after multiple reboots :slight_smile: So i guess my problems are fixed.


Great news!

I know I sound like a broken record, but I can’t help it: Thank you so much for providing comprehensive and speedy info while debugging this issue (well, issues :slight_smile: ).


Thank you for the quick fixes :slight_smile:

1 Like

Which are meant?

Those should be the PRs fixing the issues found here (or even more), latest nightly has them, next release containing them will probably take a while:


Is the result maybe v1.12.0-rc.4 ?

New 0.12.0 RC would be for fixing things we specifically broke in 0.12.0, I don’t think these are that.

1 Like

So is maybe fixed in v1.13.x? Since I think about the stuck problem with the versions after v1.10.0.

The bugfixes being made currently will go into the release after 0.12.0, yes. (For the moment it looks like we’ll call it 0.12.1.) There are also the nightly builds for the impatient. (I realise these are not easily available for your Synologies.)


On a Windows 10 device, I tested whether the current nightlys (I’m an impatient tester … :face_with_monocle: :crazy_face:) change something. However, it is then a mixed environment with v1.10.0 with v1.12.0-rc.3-nightly, maybe that’s not okay.

On the Windows 10 device with v1.12.0-rc.3-nightly and all the others except one everything was synchronized, but on that one device with v1.10.0 the synchronization got stuck:



I then went back to v1.10.0 on the Windows 10 device, after which all devices were OK and synchronized again.

Has the issue been resolved in the upcoming v1.12.1, or will it come later?

The sentence just before the extract you quoted answers that:

For me it seems not sure.

What is not absolutely certain is precisely what the version will be called because that depends on what changes goes into the version, and development is still ongoing.

1 Like

That’s how I understood it. It seems to me that with the beginning of v1.11.x there is a bug or condition that will continue to exist until v1.1x.x until it is corrected or changed. Such is my interpretation and hence my question. Maybe there is an assessment of it.

Let me try again.

  • The bug has been solved.
  • It will be in the next release.
  • The next release will probably be called 1.12.1, but could theoretically become 1.13.0 due to changes between now and then.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.