Connected but not syncing

Hi all, new to syncthing so please bear with me. Have tried to find the solution through the forum like restarting syncthing but still cant get it to work.

So I have syncthing (v. 1.7.0) installed on:

  1. openmediavault 5 through docker;
  2. my android phone; and
  3. my windows 10 laptop.

I have all of the connections setup between the above 3 devices. All showing as connected.

From openmediavault drive to my phone created a shared folder but it says syncing 0% and there files not syncing are listed in the out of sync items.

Can anyone help please?

Is it version 1.7.0 everywhere? Did you share the folders with each other? Did you try pausing unpausing the folders?

Screenshots would be useful

Yes its version 1.7.0 everywhere. Tried pausing/unpausing folders.

On my phone, it shows under Devices - OMV “Up to Date”. Under Folders, nothing - do I also need to add the folder from OMV here as well or is that automatic once it links?

Now its disconnected and I’m getting ‘context deadline exceeded’.

EDIT: Its gone back to my screenshot of syncing 0%.

Do you have a screenshot from the other side?

I managed to get it to work - It seems you have to add the folder twice. Once on the server side and then again on the other side (in the app) and then it began syncing. I thought it would just automatically link it once the devices are connected.

But thanks for pointing me in the right direction. I spent weeks trying to get resilio to work and gave up. Yet in 3 hours since I started syncthing - it all works.

Just a another related question on the app, is it possible to add a password or is that only on the webUI?

Password to what? There are no passwords for folders.

Password to access the app like there is to access the webUI.

May have spoken too soon, the sync folder between my openmediavault and phone got up to 69% and now has stopped for over an hour. Tried restarting all devices, pause/unpausing but still not moving from 69%.

We don’t ship an app, you access it via web, if you have an app, you have to talk to whoever built the app.

Check logs for errors if its stuck.

The logs keep saying ‘connected to myself’ - should not happen.

There should be something else, or they should stay disconnected. It’s best that you post screenshots and logs from both sides.

Not sure how to post the logs/screenshot from the phone side? I also see a lot of ‘addresses’ in the logs - i presume there is nothing private in those logs when posting on the web?

Not really, as long as you don’t that accepting random devices.

You have failed items, you should fix those.

sorry can you explain further?

Your UI is showing failed items, if you click on the text it will open a dialog with errors.

Appreciate your help thus far, but I am still not sure of what I am fixing. I can see loads of errors in my logs but dont know where to start.

Did you actually find what I am referring to?

No - can you be more specific?

Look at your first screenshot, look at the folder box element, read each row in that element.