Can't connect to web GUI

I’m running my syncthing instance on a headless Debian 12 server in my local network. When I run the syncthing command all looks well and I get a message saying the web GUI is up on but I’m wondering how I can connect to it from another computer in the local network as currently just switching the IP to the private IP of the server doesn’t work. Thanks for the help!

Did you only change the URL from to http://x.x.x.x:8384/? (where x.x.x.x is your private IP address).

If so, there’s an additional required step. In Syncthing’s web UI, click Actions → Settings → GUI and update the address and port number Syncthing should use. For more details, see Syncthing’s documentation: The GUI Listen Address

And for additional tips and security considerations, just a few of the earlier forum threads:

Hey Gaget,

Sorry my other post wasn’t very clear I’m wondering how I can change the address the web server is on and haven’t yet. Thanks for the help!

Either use an SSH tunnel, or stop Syncthing, edit the config.xml file and replace the listen address with whatever you want.

See Syncthing Configuration — Syncthing documentation for details.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.