Accessing server from desktop computer

I recently reinstalled syncthng on my server and need to start over.

After installing it on my server, I configured syncthing to get access from outside my server, so that I can access the GUI.

Two things: 1 - the GUI is still not available. I updated the config file: 0.0.0.0:8384

2 - when rereading the documents, it talks abut setting a good password. Where does one set the password? I do not recall how I did it the first time.

Thanks

Joseph

What kind of OS is the server using? You may need to allow inbound access for Syncthing in the firewall first.

HI.

I am using Ubunto 20.04.

The new server(I migrated from an old one) is in the same network that my old working syncthing was working.

The firewall (pfsense) remains unchanged as well.

In case I did nto specify, I use: myip:8384 to try and access my server.

AS well, the desktop computer trying to access it is on the same network using the local IP. I do not leave the local network when trying to access the webpage.

I cannot help with Ubuntu specifically, but just in the last few days I was configuring a new Syncthing installation in Windows, and the only thing that I had to do was to set the GUI listen address to 0.0.0.0:8384, and then allow inbound access in the Windows Firewall.

I would guess that something must still be blocking the access in your case. This is all under the assumption that Syncthing is running fine on the server. Can you access the Web GUI locally from the device itself? Of course, this will be problematic if you have no graphical UI there… Even then, you should still be able to check if the syncthing binary is up and running though.

Hello,

I can not access the server in GUI mode. It is a server.

But, I can say that it is accessible from my desktop, because on my desktop, I can add a remote server using the multi letter/number code find when looking at the start up text after running. It connects, so it is running.

Check if syncthing is running and listening properly:

netstat -tulpn

On a properly configured system you should see a line which looks like this:

tcp6 [...]  :::8384 [...] LISTEN

Hello,

Here is what I got as a response:

tcp 0 0 127.0.0.1:8384 0.0.0.0:* LISTEN 1986030/syncthing tcp 0 0 0.0.0.0:40355 0.0.0.0:* LISTEN 1986030/syncthing

Does this help?

I notice that it listens to 8384 locally. THis is odd, because I changed the line in the config.xml file to read:

<gui enabled="true" tls="false" debugging="false">
    <address>0.0.0.0:8384</address>

But, in the response, it says 127.0.0.1

THanks

Joseph

Are you sure that the config.xml where you changed the address is the actual file that Syncthing is using? The default location should be $HOME/.config/syncthing, but this may very depending on how you install and/or launch the program. Also, you need to restart Syncthing after editing the config file (or ideally edit the file with Syncthing shut down).

On a side note, not exactly related to the issue, but still because Ubuntu is involved, have you installed Syncthing using the packages from https://apt.syncthing.net?

Hello, Thanks for the ideas. I did modify the config.xml file in: HOME/.config/syncthing

As for install, I used the syncthing website install instructions:

https://apt.syncthing.net/

As for your idea of stopping and restarting, I tried this as well after you suggested it.

I also looked at my desktop syncthing, and it is “disconnected”.

I can restart syncthing and share the start up text that appears in the command line.

Thanks

Joseph

Which user is running syncthing?

It is being run as my normal user, NOT root.

I recall it saying not to run as root.

Is it executed as the syncthing user? Maybe you’re editing the wrong config file. You could also open the Web UI by accessing port 8384 via SSH port forwarding and change the settings.