cannot access localhost:8384

I’m watching the video at Syncthing Made EASY - YouTube I used SyncTrayzorSetup-x64.exe I’m attempting to install on my Win10 desktop and Win11 laptop. On the desktop when I enter localhost:8384 it works but when I enter it on my laptop I get “This site can’t be reached localhost refused to connect” ERR_CONNECTION_REFUSED I ran a google search for the error but did not find anything that resolved the issue.

As I installed I try to perform the same actions on both systems.

The laptop is new and I have a long way to go before it is setup.

Try http://127.0.0.1:8384/ instead of localhost:8384.

The familiar web browser address such as https://forum.syncthing.net/ is known as a URL (Uniform Resource Locator):

  • https is the connection protocol.
  • forum.syncthing.net is the server address (aka., website “domain name”).
  • / refers to the “document root” (the highest point in the document tree; the branch that contains all other documents on the server).

The optional portion is the network port number. If it isn’t specified, it defaults to 80 for http and 443 for https. So the following URLs are functionally equivalent:

https://forum.syncthing.net/
https://forum.syncthing.net:443/

Most web browsers will let users enter just “forum.syncthing.net” and then try multiple variations of the remaining parts until success or failure.

localhost:8384 is interpreted by a web browser as being short for http://localhost:8384/.

However, “localhost” isn’t normally a valid domain name. It’s actually an alias for the internal network IP address “127.0.0.1”.

So on most operating systems, the following two URLs are functionally equivalent:

http://localhost:8384/
http://127.0.0.1:8384/

Not all computers have a proper network configuration, so “localhost” might not resolve to “127.0.0.1”. On Windows, check the “hosts” text file:

C:\Windows\System32\drivers\etc\hosts

Errors can also occur when a web browser’s DNS lookup is misconfigured or a web browser is configured to only search for valid domain names.

What is the reason you’re trying to access Syncthing through a Web browser though? SyncTrayzor offers its own interface (that can be launched through the tray icon). If you’re going to use a browser instead, SyncTrayzor with its full-fledged interface becomes kind of unnecessary (unless you only care about the tray icon and notifications).

gadget - I’m using Chrome as my browser on both systems Nether of the suggested URLs are now working on either system

Following is what I see in the host file on both systems

Copyright (c) 1993-2009 Microsoft Corp.

This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

This file contains the mappings of IP addresses to host names. Each

entry should be kept on an individual line. The IP address should

be placed in the first column followed by the corresponding host name.

The IP address and the host name should be separated by at least one

space.

Additionally, comments (such as these) may be inserted on individual

lines or following the machine name denoted by a ‘#’ symbol.

For example:

102.54.94.97 rhino.acme.com # source server

38.25.63.10 x.acme.com # x client host

localhost name resolution is handled within DNS itself.

127.0.0.1 localhost

::1 localhost

127.0.0.1 localhost

@tomasz86 let’s consider this a dumb user error. On both systems I can click the start button type syncthing and a syncthing window opens when I click on start syncing on either window I can see that it is attempting to run and then I get message that it failed.

I assume that it fails because it is correctly setup (I’m lost at this point and don’t know how to set it up. Following is what I see in the Syncthing Console on my desktop.

I attempted to paste the Syncthing Console contents in this reply but the darn forum will not let me post it.


My documents folder is located at Desktop > R:\Libraries\Documents Laptop > D:\Libraries\Documents

The drive R is a 14TB drive on my desktop and has all of my Libraries The drive D is a partition on the SSD boot drive (1TB) in the laptop

In the video I was watching it mentioned that that I have to identify what folders I want to sync. I understand this is necessary, I just don’t know how to do it in Syncthing. BTW I’m using SyncTrayzor 1.129

In the settings of ST it states “Folders unavailable. Please start Syncthing” however I have not setup what is to be synced in Syncthing and thought that I had to do the setup through the web interface.

Sorry to be such a dummy but I’m totally lost.

When I attempt to post in the forum I keep getting “An error occurred: Sorry, new users can only put 2 links in a post.” IMHO this seems totally wrong and very unfriendly.

tomasz86 I created a reply and started it with ATtomasz86, when I clicked the Reply button it disappeared. I have no idea what I did wrong.

Let me see if I can recreate the post

I was attempting to setup Syncthing and thought I had to do it through web interface.

I do have SyncTrayzor installed, when I click on “Start Syncthing” it fails. I assume that it fails because I have not set it up. I realize that this is necessary but I don’t know now to do the setup.

I’m using SyncTrayzor version 1.129

I want to sync my Documents folder on my desktop (R:\Libraries\Documents) to the Documents folder on my laptop (D:\Libraries\Documents).

The R drive is a 14TB drive in my desktop and has full share to anybody that is on my network.

The D drive on a partition on the boot SSD (1TB) on my laptop and is NOT shared out.

I desire to keep the two Documents folders/libraries in sync and if I add another PC I’d like to add it into the syncing. The Documents library is about 92GB in size. I was about 50GB larger but I recently archived a large portion of it.

In the original post I attempted to include include the Syncthing Console but I click on the reply button in the draft reply I get error stating as a new user I cannot include 2 links. This confused me, I then cut that section out of the reply and it then worked.

The contents of your C:\Windows\System32\drivers\etc\hosts file below looks fine. All lines that start with a # are comments so only the last line 127.0.0.1 localhost is actually used.

So barring anything unusual about your Chrome settings – and assuming that Syncthing is actually running – http://localhost:8384 will work.

If you’re using one of the Syncthing wrapper tools such as SyncTrayzor, some or most of the configuration can be done without using Syncthing’s web interface.

However…

I think for many, if not most, Syncthing users getting started for the first time should use only the official packages because:

  • The official documentation at https://docs.syncthing.net/ focuses on the official packages and most 3rd-party tutorials on YouTube and elsewhere also focus on the official packages. It’s much easier to follow along if the instructions match what you’re going to encounter in the official web interface.
  • All of the 3rd-party installers and wrappers recommend visiting https://docs.syncthing.net/, https://forums.syncthing.net/ and https://github.com/syncthing/syncthing/issues for help.
  • As popular as SyncTrayzor is for Windows, the number of users on this forum familiar with Syncthing’s native interface(s) greatly outnumber those using alternative interfaces, so help will be much quicker and easier to find.

Syncthing will start just fine before it’s fully configured because the first start does a bunch of internal housekeeping such as generating a minimal configuration file, security certificates, etc.

SyncTrayzor’s bottom panel displays diagnostic/log messages. There should be some clue as to why Syncthing fails to start.

But as I explained above. I think you’re better off uninstalling SyncTrayzor and anything else related to Syncthing. Once you have a clean slate, I recommend reading at least the two following webpages before installing one of the official Syncthing packages for Windows (you’ll happy you did :wink:):

Another very helpful page well worth reading is:

Please check the SyncTrayzor logs and copy and paste them here. The whole idea of using SyncTrayzor is so that you don’t need to access the Web GUI separately :wink:. Are you trying to run both the syncthing.exe binary and SyncTrayzor at the same time by any chance? If yes, this would be the reason why SyncTrayzor is unable to start, because it’s trying to use the same configuration as syncthing.exe is already using, and fails to do so. If that’s the case, please close the console window of syncthing.exe completely, then try to run SyncTrayzor again.

Also, if possible please post screenshots of what you’re seeing on the screen which should help greatly diagnose the problem properly.

Although this is true for some other wrappers that try to reimplement the Web GUI, SyncTrayzor essentially displays the Web GUI itself, so interacting with it is no different than doing it in a browser separately (and all the configuration can be done inside it).

However, SyncTrayor is the officially recommended solution for Windows users (see https://syncthing.net/downloads), so while not packaged by the Syncthing team, it’s essentially the official way to install Syncthing on Windows (which makes it different from all other wrappers, except for syncthing-macos which is also officially recommended).

Basically, what I’m trying to say is that it can be very confusing to the user if SyncTrayzor is recommended to them at the very top of the official download page first, but then they’re told that they should ditch it and switch to the bare Syncthing binary instead :upside_down_face:.

tomasz86 - I’m assuming that what you want to see is the Syncthing Console that is in the bottom half of the Synctrayzor window. Tonight it seems to be in a loop whereas last night I’d get a FAILED message in the tophalf of the window and the bottom half stopped updating.

BTW When I press the Reply button after creating my reply I get a message stating “An error occurred: Sorry, new users can only put 2 links in a post.”. What the heck does this mean and how do I prevent it? This is stopping me from posting the contents of the logs.

Is it possible to include images in my replies? If yes, how in the heck do I include the images.

OK it seems that a simple copy the image to the clipboard and then paste it into the reply.

You’ve (re)installed SyncTrayzor and it downgraded your Syncthing, which now doesn’t understand the config and database created by a previous (newer) version. This is a common SyncTrayzor problem. There are threads about it here on the forum and on their issue tracker, the solution is to drop an updated Syncthing program wherever it is SyncTrayzor expects it.

YEA, thanks for the feedback. I used “Everything” (search application) to find the locations of Syncthing.exe and pasted the latest copy of the EXE into the folders that Everything identified. Now I can run SyncTrayzor.

It is rather late and I’m tired. Tomorrow I’ll try to setup the folders I want to sync. Thanks again!!!

So I installed SyncTrayzor, set up my first folder, closed out and re opened syncthing. But the second time I opened it the Localhost:8384 wanted a user name/password. Ive tried everything, nothing works. Ive tried reinstalling it but it still asks for a user name/password before I even get to the UI. Any advice?

Are you sure there are no other instances of Syncthing running at the same time? Alternatively, have you by any chance installed Syncthing previously and set a username and password then? Nevertheless, if you simply want to reset Syncthing to the initial configuration, I’d advise to follow the steps as described in https://forum.syncthing.net/t/name-and-password/19641.