All Settings Lost Pt. 2

I came across this thread when trying to troubleshoot a problem with Syncthing this morning:

All settings lost

It identically describes the problem I was having. That thread seems to be closed and doesn’t allow replies, but it seemed relevant to mention that someone else had experienced this.

I hadn’t touched Syncthing settings in a very long time, and it has worked wonderfully for me up until this point. The solution described in that thread worked for me, but I ultimately agree that it’s unsettling that it happened.

You don’t explain how you run syncthing or how you installed it, but based on what’s in that thread, the way syncthing is run has changed, which is what caused it. I suspect the same thing has happened to you, which I don’t think is syncthngs fault here.


Generally when people have “lost” their settings it’s because they are running Syncthing under a different user than before, or with a different value for $HOME, or in a Docker setup that doesn’t persist the configuration volume.

Given the steps in the other thread helped, that clearly seems to be the case here.

Thank you, Jakob, for a more meaningful and less needlessly hostile/combative response.

The things you mention - switching users, changing $HOME, or Docker use - seem like very big, obvious things that I should easily be able to identify as different. I’m not sure how I could “accidentally” do any of these things. My Windows machine has more or less been sitting idle or being used for normal daily tasks - I don’t use Docker at all on it, nor have I done anything that I could identify as modifying my $USER or anything like that. Nor have I touched Syncthing’s configuration at all in literally years.

It’s entirely possible that some uninvited-but-inevitable Windows update has thrown things off, but again, such an update would be a minor, routine patch, not a full system overhaul.

It may well be the case that what you’re suggesting has happened has indeed happened; I’m not doubting you, but I am puzzled, and have been caught off guard by the experience.

In any case, I googled around, found that other thread, and was able to fix my problem. The fact that the thread was closed but that I had experienced the same thing seemed like it might be interesting to the developers of Synthing, but then again, maybe it isn’t. I was just trying to be a good citizen by mentioning it - I didn’t come to cast blame or vilify Syncthing or its developers.

I found and installed Syncthing once, about 4 years ago, and have literally not had to mess with it in any way since. I can think of no other piece of software I have ever interacted with that requires so little in the way of upkeep; for this I’m very grateful.

1 Like

Again, adding details of how you run/auto-start syncthing, how you installed it, might be useful here.

I am sure Audrius response wasn’t meant to be hostile/combative and I don’t read it that way. It just pointed out that in the thread you are linking, a cause unrelated to Syncthing has been identified, and that if you think that one does not apply to you, we need more information about your setup.

The thread is closed because it is a support thread and those get closed after 30 days of inactivity. The rationale being that we want new reports in separate topics, because as often as not the issues aren’t the same, even if related.
I didn’t and still don’t read your post as vilifying anyone or anything. The question I has was: What do you want? That may be an incorrect notion, as apparently you didn’t want anything beyond giving a heads-up, that you also experienced said issue. It’s easy to fall into that mindset, as usual support request are of the type “here’s my problem - fix it now!”.

The issue here is apparently Microsoft deciding to change an environment parameter in a “minor” upgrade (they call some of their updates feature updates, but then again it’s not presented as something major, e.g. I didn’t encounter any naming change or changelog).

I am very happy that you like it. I do also appreciate the low-maintenance aspect of it a lot.

@Simon, you’re right, I don’t really want anything, and I wasn’t blaming anyone; I was just trying to be helpful. I get you guys are slammed with people demanding action when something breaks. I’m not that person. If I’d built a thing and it stopped functioned in an unexpected way for someone, I’d want to understand why.

I installed Syncthing 4 years ago, so my memory of how exactly I did it is hazy. I also don’t remember how I set it up to auto-start, so I googled “how do I auto-start syncthing on windows”, came across a doc explaining how to do it with the Task Scheduler, and went to see if that’s what I indeed did. And it seems that’s how I DO run/start it. It seems to run under my own user account, whether I am logged in or not. The Trigger is “At system startup”. Syncthing itself is located in my user/bin directory.

It seems like everything I’ve done to set it up is at the user-level.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.