Wrong status (disconnected/up to date), speed


(Eyal Lior) #1

I’m trying to sync my phone and laptop. More often then not the connection is dropped and also, even when it’s syncing I get wrong status on bpoth laptop and phone. I.e. right now the phone says syncing (device) 5%, and the computer says “up to date” (device) while the directory syncing says “syncing 6%”.

Another issue is speed - I get 25-50 KiB/s, why?


(Audrius Butkevicius) #2

Some of these are answered by the FAQ.


(Eyal Lior) #3

The sync actually fails almost always. I just started the app, it synced a few files, then left the most newest file on phone and didn’t sync it. The folder says “Error”. The device is 99% of the time “Disconnected”. There has to be a way to get an explicit detailed status and reason for the Error and lack of connectivity. This is ridiculous.


(Catfriend1) #4

Which version do you use?


(Eyal Lior) #5

14.47 I think I know what the problem is. I tried other apps to sync phone (Xiaomi Redmi 4 note) and laptop, and couldn’t get through to the phone (using ftp i.e.) So I figured that phone comes with firewall and since it’s not rooted, I can’t deactivate it (don’t even see a grayed out option) Weird though that it did work for some files to be synced…


(Catfriend1) #6

Just a wild thought: does disabling the local discovery in syncthing options and setting static ip adresses according to the docs help?


(Catfriend1) #7

Do you still need help on this?


(Eyal Lior) #8

Tried this, it didn’t help.


(Eyal Lior) #9

I gave up on Syncthing. Completely unreliable, and UX is bad - I would add a “sync now” button that will report a meaningful result status whether it succeeded to sync or not. I can’t just sit and wait an our for the program to decide on it’s own when is it time to start another sync attempt.