Wrong IP address for relay lookup

Hello everyone,

I’ve changed recently my internet provider, and thus the equipment with it. Since then, my linux server’s syncthing won’t fetch any data from relays. This is because it tries to load them on the wrong IP address :

[UKXD2] 19:26:16 INFO: Relay listener (dynamic+https://relays.syncthing.net/endpoint) shutting down
[UKXD2] 19:26:16 INFO: listenerSupervisor@dynamic+https://relays.syncthing.net/endpoint: service dynamic+https://relays.syncthing.net/endpoint failed: Get "https://relays.syncthing.net/endpoint": dial tcp: lookup relays.syncthing.net on read udp> i/o timeout

The IP doesn’t exist anymore, and should be now.

I tried to find how to fix this using the GUI and the config files, but I can’t find anything related to it.

Does anyone have a clue ? Thanks in advance.

The IP mentioned is the one of your (supposed) DNS server. You may need to double check your DNS or DHCP settings.

I changed the gateway to .254 as I lost internet access. Now it’s back online, but the DNS was already to

# /etc/network/interfaces
auto lo
iface lo inet loopback

allow-hotplug enp3s0
iface enp3s0 inet static

Are you trying to change your IP address? For me, I use VPN and Proxy if I need to hide my IP.

Nope, I just wanted Syncthing to stop requesting to But as @calmh mentioned, finally it was the network which wasn’t stable. I could ping Google from it, but I couldn’t request anything outside. To fix this I just set the network to default dhcp, reboot, then re-set the previous static IP, and now it works like a charm.

Thanks for your help anyway, this topic can be closed.


Actually, I don’t know much about it. I also would like to learn more. Thank you so much!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.