Windows XP Issue -


(charles) #1

Hello - Syncthing on WinXP starts…then stops after a couple seconds??? Syncthing has been working fine for months on my Windows XP installed as a guest (with the host being Linux Mint), using KVM (kernel based virtual machine). I have 7 computers set up this way for my business. Suddenly, Syncthing will start, and within a few seconds, stop. I’ve tried to capture a couple error messages, which include:

  1. syncthing failed to find GetFileInformationByHandleEx procedure in kernel132.dll
  2. syncthing exited: exit status 2

The Syncthing version I had been using was v1.0.1. The issue happens when a forced (not optional) upgrade to v1.1.0 occurs. I did find a “similar topic”, and I tried it, but with no success. The topic reads: “Are you running syncthing.exe with -no-restart? Normally syncthing runs a monitor process, which restarts the main syncthing process if it exits, which is disabled by that flag. In upgrade, syncthing shuts down and the monitor process restarts it. If you’re not running that monitor process, then it won’t start again.”

Can anyone help? Thank you, Charles


(Audrius Butkevicius) #2

Use the search for GetFileInformationByHandleEx, the other thread explains it.


(charles) #3

Hello - Do I deduce from the statements copied below that Syncthing no longer works with Windows XP? Thank you…Charles

I suspect this is Windows XP which is not supported (and probably worked by accident before). Guys, return support for Windows XP, and this is famous for your synchronization that works everywhere! We will not compromise on security patches landing in Go to support an unsupported (by anyone) operating system. If you want, build it and maintain it yourself. XP, 2003, Home Server (which is 2003-based) are all dead in the water as of Go 1.12 / Syncthing 1.1.0. Right, Windows XP as I suspected. Sadly, you are out of luck, as even Go itself no longer supports it. Upgrade your OS.


(Bt90) #4

Correct. You can still stick to the previous version.


#5

Really? Windows XP? I think your first sorrow shouldn’t be any software, it should be your OS! o_O


(charles) #6

Hello…thank you for your reply, and suggestion. I’ve been trying to use the previous version. When I click on the previous “syncthing.exe”, it loads right up - even into a browser. But then immediately, it jumps to the message about having updated to the later version and will restart in one minute. Then it just goes dead. Can anyone help me out? I did make a donation before ($100 at Syncthing, charles@newlands.com, Mastercard, 5404, February 25, 2018, #1380-1338), and I’d certainly do the same now…if I can get going again. So, the previous version is fine with me.

Also, I just remembered that in Actions > Advanced > Advanced Configuration > Options > Auto Upgrade Interval (hours) I had set the hours to “8760”, which is 365 days (I guess this being about a year ago when I set up Syncthing). I think I remember that once I had Syncthing set up and working, don’t let an upgrade mess things up ("if it’s not broke, don’t fix it). Perhaps I should have set the hours to a higher number?

The main reason for sticking with XP is that my customer database and reservations (for my trout fishing lodge in Arkansas) is written in Visual FoxPro - which only runs on XP. And also for Quickbooks for my accounting. Everything else, I use Linux Mint…and I’m upgrading to version 19.1 currently.

Thanks again, and any help would be appreciated - Charles


(Jakob Borg) #7

Set auto upgrade interval to zero to disable. Even with a long time interval a check is done at startup and then after the interval.


(charles) #8

Hello Mr Borg, thank you for your email, and suggestion. I tried to use a previous version (v0.14.43 - 13,003 KB), setting the update to “0”, and it seems to have worked on four laptops so far. Might you suggest any other tips in my effort to hang with WinXP, such as “Watching for Changes”? Or anything else?

Also, I mentioned about my Linux Mint upgrade to version 19.1. What I’ve already done is install v19.1 on a laptop and got Syncthing installed and up and running. I’ve got the Kernel based Virtual Machine set up, and I’m about ready to import the Windows XP image (where Syncthing is already installed) into the virtual machine. Once everything is ready, I’ll be “clonning” the hard drives to all my other identical laptop computers. I suppose before clonning, I should un-install Syncthing from both Linux and XP…then at each computer, re-install Syncthing? Or would Syncthing be able to determine it’s on a different computer?


(Simon) #9

Why v0.14.43? If this error came up in v1.1.0, I’d try v1.0.1 and go backwards from there if that doesn’t work either.


(charles) #10

Hello Simon, thanks for your suggestion. Is there anywhere to download previous versions of Syncthing?


(Bt90) #11