Windows Server 2008?

I have an old server (which needs to be upgraded, but not today).

Previously, Syncthing and BitTorrent Sync were just about the only things that would even install to include this device in global synchronization. When Resilio took over, BTSync ceased to function on this version of Windows, and I discovered and used Syncthing successfully for quite some time.

I hadn’t fired it up in a while (hadn’t really worked on these files remotely) but now I’m having issues. Of course, the version I have running on that server is very old (0.10.29). It always worked, so I never upgraded.

Remotely, I installed the latest version (0.14.47) on one of the Windows 10 stations in my house and it setup beautifully, automatically detecting my UPNP router, reporting to global discovery servers, etc. etc.

But of course … 0.10.29 no longer connects to anything, although local discovery with the laptop I used a while back running the same version works just fine.

I tried installing 0.14.47 on the Server 2008 box (not R2), and like every other sync package in existence, the installation program does absolutely nothing. It never opens, never gives an error, just nothing.

So I think I’m stuck, unless …

  1. There is a replacement for the old “Announce Server” used in 0.10.29 that I can specify in the settings there. Of course if it’s not the same discovery server used in 0.14.47, then I’ll have to make changes there also.

  2. I can setup my own discovery server (either in the office, or the home office) that would be compatible with both versions.

  3. There is an intermediate version (later than 0.10.29, but prior to 0.14.47) that might work with Server 2008 and communicate with the current set of discovery servers.

The only thing I’ve tried so far is to specify the discovery server in 0.10.29 as: udp4:// (I changed the port from the 22026 default, because that didn’t seem to work either). But it’s still giving me “Global Discovery: 0/1” I really didn’t expect it to be that easy, but I figured I’d take the shot.

I’m not averse to making changes at either end, and/or setting up my own discovery server. But before I put any more time into this, I’d just like some assurance that the situation isn’t completely hopeless. A bit of guidance as to what path to take would be helpful as well.


0.10 and 0.14 are incompatible. Compatibility breaks on every version increment. There is no 0.10 discovery servers available, and even discovery between 0.14 and 0.10 is not compatible, so there is no way for your decides to talk.

Thanks for the quick reply. I had figured that was the case, but you saved me some time in your confirmation.

I am happy to report, however, that the story has a happy ending. Though I can’t say that I understand why.

Attempting to install the latest version of Syncthing by running the EXE file obtained via the download package didn’t seem to work. However, opening a command prompt and running “syncthing -update” from the installed version seems to have worked just fine.

My Windows 2008 Server is running 0.14.47 now, and after a few configuration adjustments, I’m synchronizing files between the office and home office as I’m writing this.

Thanks again!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.