Windows -> Manjaro goes to wrong folder

I set syncthing up, and not realizing the potential consequences of selecting ‘all users’ for Windows, I ended up having to run icacls “C:\Users\username (my username)\Documents” /grant “SyncthingServiceAcct:(OI)(CI)M” /t in order to get the initial syncth going, which worked well. When I ran that command, it applied it to all then-current folders and files, you could see them scroll by as it ran. Now, a new file saved to username/Documents on Windows is getting saved to /home/username/Documents/otherusername/Documents on Linux even though on Linux the path is set to ~/Documents EDIT: Saving to ~/Documents in Linux works perfectly, goes to /username/Documents in Windows Ideas on how to fix this?

And now, whatever I did, new files are supposedly going to spbkw-xxxxx instead of documents, but Catfish can’t find them at all… ?

Sorry, but I’m not sure how this is a syncthing issue. Syncthing just syncs files wherever you point it to, so your issue is somewhere else.

I guess you can try absolute paths in both cases.